Rhino running slow

I’m trying new Rhinoceros on my quite new (6 months old) computer.
When I open some files I’ve created on my old laptop, I thought that on the new comp I would run much better, and I acctually can’t see any difference. Even opening file takes forever. Please, help me to make it better. The new comp is in the service now, but after many tests they’ve made, they say there is no equipment problem. They even colected brand new work station and installed trial on it and it is still having proplems.
The problem is that the program stops working, says “no response” but the efficiency app shows CPU useing not even 5%, RAM about 10%, graphics up to 5%… I don’t know how to let Rhino use all the computer potential… Can you please help me? Thank you.

System info:

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-N1U2GTK

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 SUPER (NVidia) Memory: 8GB, Driver date: 4-3-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 445.87

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-3-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi @multumpaulina
You should start by updating your graphics driver. It’s almost a year old, and that’s a lot in terms of graphics drivers - especially for a GeForce card!
HTH, Jakob

Edit: also make sure your Windows installation is up-to-date :grinning:

Hello - you mi9ght also try disabling VRay in Options > Plug-ins page and then closing and reopening Rhino - is that any better? Is the slowness related to particular files, or does it happen even in a new file?


And empty files opens normally.
It’s related to files which weigh a little. My files I’m working on usually weigh about 200 - 600 MB and Rhino is slow even on the 200 MB ones.

Hi - did you update drivers and the OS? Did it get better once you disabled V-Ray? Is this specifically related to opening and saving files? If so, where are the files stored - locally or on a network / cloud service?

Hi. Sorry about the delay with replying. I have been off for few days.
Well I can’t try disable V-Ray because my computer is still in service but I can’t emagine working without V-Ray so… And it’s not related to opening and savings. It happens even when I move line and press ctrl+z → it takes few minutes to “wakeup”. When I’m turning around the model it’s simplificating the model to rectangles (no matter what it is - even plants has rectangles instead every single leave).
And CPU, RAM, graphics are not even 10% in use then.