Rhino Render folders and files with materials, textures, environments, etc

As I was just playing around with Rhino Render, and I wanted to add an environment map I ended up in a place where I could seemingly choose several items, but none were accessible. I could add textures from here, but I could not find these folders via the textures dialog in the materials panel, since as you can see all of these folders and files seem to reside inside the Contents folder of the Rhinoceros app file.

When I follow the same path via “Show Package Contents” a couple of times, I can find the original Toucan materials, as well as all these folders with materials etc.

I could not figure out how to apply any of these new materials to objects in Rhino.

Are these place holders for future implementation or am I doing something wrong?
These are some of the folders and files I found via Rhino Render, as well as in the Finder.

Hi Zews - if you are adding the environment map itself, look for a folder
with images in it - png, jpeg/jpg, tiff, bmp
as in the last image. I cannot remember off hand if Rhino for Mac can use
an hdr image, I’ll check tomorrow.

It can use HDR

You should not have to dig around in the Contents of the app-bundle itself. (I think we need to better document where this stuff lives, or make it a bit easier to get to). In the meantime, render materials, etc live in:

~/Library/Application Support/McNeel/

(This is your library, not to be confused with the system-wide library).

Not everything you found in your app-bundle archeology will live there “out of the box.” Only materials you have added to the “Custom Materials” library…though you don’t have to change anything in the default materials to make them “custom” - just drag them into Custom Materials. Which brings us to the easiest way to find this stuff…

To get to this folder, right-click on any of the Custom Materials in the Material Editor’s Library (left-hand side) and select “Show in Finder.” This should open the proper folder.

Hi, just downloaded the latest WIP - 5A808w - and am having problems trying to render with textures. It seems as if there aren’t the textures for the default materials (see my screen shot)

I tried a search for Marble.png and found nothing - apart from a set from another program - I tried @dans’ method and it gives me the above screenshot. Have I missed something? TIA

Just been reading the thread on Rendering time comparisons… and I am running on Mavericks 10.9.5 - could the problem stem from this?

There are standard materials, custom materials, and model materials. By “default materials”, do you mean the custom materials, because that is the folder you are displaying in your screen shot. The original .png material files are buried deep inside the Rhinoceros application right now. They won’t show up using search. References to the png files are copied when you copy materials around.

If you right click a custom material and select “Edit library material” in the context menu, you see this:

If you click on the texture Map file: field, you can see where the file is located, and also browse to replace the material with another.

Hi Marlin,

Sorry to be confusing – what I was trying to show (badly) is that the standard materials don’t have their textures (.png file) that is why I was trying to look for them. I dragged a couple into custom materials so as to be able to right click and find the path to where the file is located as you show.

Here is a screen shot of a test file with 3 standard materials applied (glossy black, grass and stripes) – no texture – I understand that these show up as being the model materials when applied in the model.

Here I dragged the standard material “Herbe” into my custom materials, it doesn’t seem to find the image file Grass.png

I had no problems yesterday working with my custom materials and applying “homemade” textures although the rendering time is slow.

Thanks for the help.

You can indeed see where the file is located including the complete path, but that is of little use, because as I mentioned in my original post, the file is buried deep inside a folder deep inside the Rhinoceros application file. I mentioned in my post that you have to right click a file twice to open “Contents” in the Finder to get to that folder.

When you click on the “Textures” folder below the “Marble.png” file nothing happens. That folder is not accessible via the material edit window.

I wonder if these files are kept here because this is still a WIP.


The standard materials still can’t find their .png textures (5A851). I can’t find the folder either, I do a search for grass.png for example, nothing…

I see this (MR-2160). Thanks for reporting. Sorry for the slow uptake.