Rhino plugin disabled


(Andrew) #1

I am re-posting this question because further work has shown that the original post title was not accurate, and the post had ground to a halt.

The problem is that our plugin, which is derived from a rhino 5 commons plugin, loads ok but is treated as disabled on the next rhino launch.

We normally install plugins for Rhino 4, 5 and now 6 programmatically, but the same problem occurs during a hand install, so I will show the steps for that:

a) install the plugin from the options by hand:

Plugin appears to be loaded OK:

Plugin responds to commands , all looks OK:

image

But on next rhino start this message box comes up:

image

And looking in the options plugins we see that the plugin is disabled


(Dale Fugier) #2

Hi @andrew3,

Is this repeatable? If so, can I get your plug-in so I can repeat the problem here?

– Dale


(Steve Baer) #3

I have a copy of Andrew’s plug-in Dale and will try to repeat these steps that he just outlined


(Nathan 'jesterKing' Letwory) #4

Just out of curiosity, are you able to make changes in Tools > Options? Try for instance changing the viewport background color. I’d like to know if the change sticks after you close the Options dialog.


(Andrew) #5

Thanks for the suggestion of checking if the option changes stick.

I changed the viewport background colour, and then restarted rhino… it kept the new colour.

As far as I can see everything in Rhino (and our plugin ) is working OK… it’s just the load message on restart.

And if I tick the Enabled tick box for the plugin then that sticks, so that on further restarts the plugin loads without the warning.

But I would prefer not to have to tell our customers to do that.


(Steve Baer) #6

Hi Andrew,
I’ve tried the steps that you laid out and still haven’t been able to repeat the problem.

Try the following;

  • open regedit and go to HKCU\Software\McNeel\Rhinoceros\6.0\Global Options\Plug-ins
  • you should see an entry for 112f133a-8afd-4656-b04a-d313a05800e5 which is your plug-in’s ID
  • delete this entry; it is what sets the “disabled” flag for your plug-in
  • also go to HKCU\Software\McNeel\Rhinoceros\6.0\Plug-ins and find the 112f133a-8afd-4656-b04a-d313a05800e5 key. This is the key that holds all of the cached information about your plug-in. Delete this key too.
  • Start Rhino and repeat the steps that you laid out for manually installing. Do you still see the bug that you are describing? I’m curious in case the Global Options flag got set at some point in time and we’re just dealing with stale cached information in the registry.

(Andrew) #7

Steve

Thanks for the suggestion to clear the protected load flag from the registry.

This solved the problem.

I don’t know how the flag got there, but I can now install the plugin by hand or programmatically with no problems.

Thanks for your patience in looking into this problem.


(Steve Baer) #8

That’s great news. Your step-by-step screenshots really helped