Rhino options -> Keyboard bindings not saving global


#1

Dear community,

I have tried to find an existing post about this matter but the search tool came up with nothing.

The problem is as followed, the key-binding of F2 - !_CommandHistory is in the way of my workflow, I removed the key binding but it seems to be a file dependent setting, rather then a PC dependent setting.

So I have two questions,
A. Am I correct in assuming that it is file dependent?
B. Is there a way to change these settings for my computer rather then the files.

Cheers!

Peter


#2

It should be a global option. It works here.


#3

Strange, for me it seems to revert back to the default after a while :\


#4

Bump


#5

Bump


#6

Does it do this after an update? Or something else?

If you have customized your keyboard shortcuts/aliases, I highly recommend you export them for backup, that way if something does get reset, you can re-import them and you’re good to go. Aliases can be exported separately, to export keyboard shortcuts, you need to use OptionsExport.

–Mitch

–Mitch


#7

I have not noticed when exactly, but It seems as soon as I close/open a file they are reset, For example, yesterday i’m working on naming, using the F2 windows hotkey, and having removed the F2 from any binding in Rhino. This morning I boot up and check the setting and it has the default rhino binding again.

Making a backup might be useful, might it also be possible to make a config-file that always loads?


#8

After the last update it still exhibits the same problem, my keyboard-un-binding of F2 in Rhino keeps coming back.


#9

When you are setting your things up, do you have more than one instance of Rhino running? The last instance to close overwrites the others…

–Mitch


#10

Mitch, I think you might just have given the solution, I’m going to try that out, I tend to work in on average 3 files at the same time! : )
Thanks, this sounds promising!


#11

Sadly, it did not solve the problem : (

I tried opening 1 Rhino, changing they keyboard binding, closing Rhino, Opening Rhino, Pressing F2, it is bound again : S


#12

I can reproduce this here as well (should have tried it earlier, sorry!) so @pascal this is a bug…
–Mitch

Edit - it is not even possible to remove this via editing the registry - something recreates this when Rhino is reopened. It seems you cannot remove the entries that are already programmed in the registry completely, only change them. And you can’t put in just a simple space either…

Edit edit: You can put in just ! - if you hit F2 it will quit a running command though, or ' which will just put “unknown command” on the command line but any running commands will still be running…


(Pascal Golay) #13

Checkin’ it, thanks.

-Pascal


#14

Thanks for the help guys!


(Pascal Golay) #15

So it is possible to change it but not to have it blank/unassigned, correct? I believe that is by design for the defaults, I’ll see what else I can find out.

-Pascal


#16

It is possible to make it unassigned/blank.

It just does not save the setting, after you close rhino or open a new one the setting is back to default.


(Pascal Golay) #17

Peter, can you tell me why you need to have this blank/unassigned?

thanks,

-Pascal


#18

Hello Pascal,

It’s when I am working on renaming my layers. I use the windows hotkey F2 to quickly go to edit name. This I use because when I was using the mouse to click a layer 2 times I often clicked to fast and changed the active layer rather then changing the name.

P.


(Pascal Golay) #19

Makes perfect sense, thanks.

-Pascal


#20

Any updates on this?