Rhino opening every file as read only?

If possible uninstall this.

1 Like

My machine is managed by my school - I will see if this can be removed. Is this what is causing the issue?

Not necessarily, but I believe we have had reports where disabling that helped in similar cases.

Hello All, Rhino 7 SR21 2022-7-27 (Rhino 7, 7.21.22208.13001) - Windows 10 as of 8-12-2022 I keep getting the “Save As” error 'cuz “File opened in read-only mode”. I followed this thread and tried to uncheck the File locking as per RH-59194 post in YouTrack. Any updates on how to fix it or I’m doing it wrong? I reinstalled it twice already but nothing seems to work so far - thanks.


Try checking the Enable File locking then uncheck the Display read-only open warning, then uncheck the Enable.

Thanks - I did what you suggested Japhy above, and problem persists. I’ve uninstalled my Rhino 7 and download the Trial version of 7 as well but the same issue is happening. What I just noticed is the following: I opened the file, work on it and I can save it once, then keep working on it but cannot save it a second time (Ctrl+S), and that’s when the “File Save Error” warning shows up and check the images below: If go to the file, right click>>> Properties>>>Security, The Permissions “disappear” after I try to save the same file a second time.
To make matters worse, If I keep saving the file a second time with another name so that to avoid the “File Save Error” the Group or user names: also change, and the check marks become darker.
So, the file needs to be saved “analogously” with different name.
Not sure who can shade some light into this, thanks.
Trial Version Rhino7 also showing error


This seems like a Windows User Control issue.

Lets try SR20 before messing with the User Account Control.

I’m on SR24 and also have this problem. I’ve noticed that the .3dmbak file saved alongside the main file can be opened without issue. I’ve taken to opening those when the main file becomes locked and then saving as with a new filename.

I have yet to try every fix mentioned here as I’ve been coping well enough using the backups. I should mention that this was an issue before upgrading to SR24 (I don’t know what version I upgraded from) but not when I originally installed R7 on this computer maybe two years ago.

Here’s systeminfo in case it’s helpful:

Rhino 7 SR24 2022-11-4 (Rhino 7, 7.24.22308.15001, Git hash:master @ cb2ad12922ceb989b185972675bb705a00abb97d)
License type: Educational, build 2022-11-04
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 7.9Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 5500 (Intel) Memory: 1GB, Driver date: 12-27-2018 (M-D-Y). OpenGL Ver: 1.1.0
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
DisplayLink USB Device (DisplayLink) Memory: 0MB, Driver date: 8-11-2021 (M-D-Y).
> External USB display device with 2 adapter port(s)
- Secondary monitor attached to adapter port #0
DisplayLink USB Device (DisplayLink) Memory: 0MB, Driver date: 8-11-2021 (M-D-Y).
> External USB display device with 0 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: Off
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 1.1 (software driver)

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Rhino plugins that do not ship with Rhino
C:\Users\bryce_000\Downloads\elefront422\elefront421\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

You’ve got issues here. It appears you are running off a 1 GB video card with a 2018 driver (OpenGL1.1). Is there another video card on your machine that isn’t functioning properly? Are up to date on your windows updates?

I know - this machine has some issues… I’ve tried updating the drivers several times over the last year with no success so I mainly use it for light duty. As for the video cards, I sometimes use a docking station with an external monitor but the read-only save issue occurs when it’s disconnected, even after a fresh reboot.

I know this machine isn’t the best test case here. The previous comment was mainly to note that the backups don’t have the same problem as the main files.

Below is systeminfo without docking station plugged in

Rhino 7 SR24 2022-11-4 (Rhino 7, 7.24.22308.15001, Git hash:master @ cb2ad12922ceb989b185972675bb705a00abb97d)
License type: Educational, build 2022-11-04
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 7.9Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 5500 (Intel) Memory: 1GB, Driver date: 12-27-2018 (M-D-Y). OpenGL Ver: 1.1.0
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: Off
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 1.1 (software driver)

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Rhino plugins that do not ship with Rhino
C:\Users\bryce_000\Downloads\elefront422\elefront421\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Bryce - does the problem occur if you disable Elefront in Options > Plug-ins page and then close and restart Rhino?

-Pascal

Disabling Elefront didn’t fix the problem but this happened: I disabled, restarted the machine, opened a fresh file, created a box, saved as, modified the box then closed rhino and selected save changes and it didn’t give me the usual error. Then I opened rhino again, opened an version of a file I’ve had this problem with before, modified it, closed rhino, selected save changes and the problem reappeared. (I suspect it did this before disabling Elefront but hadn’t tested.)

In case it’s relevant, I also noticed that if I attempt to open one of the poorly saved files via the popup that appears when rhino starts I get the error “C:\file\location\file.3dm is not a Rhino file”. But if I open by going File>Open then I get the “You don’t have permission to open this file. Contact the file owner or an administrator to obtain permission.”

I also feel I should note, since it wasn’t mentioned above: the most frustrating this about this problem is that if I close rhino without having saved previously it throws up the ‘cannot save read-only file’ error from the start of this thread but after clicking okay rhino closes anyway, preventing me from saving as to an editable file and hence from opening the file later. If it wasn’t for being able to open the backups I would be seriously stuck.

Getting the same issue at the moment, exactly the same as described above by Bryce and Sergio.

I can change every file back by going into permissions for each file individually though that’s such a time suck.

Did anyone find out how to fix this problem?

Also realised that in Windows defender anti virus options there is an option to add apps / software to a list that bypasses windows firewall - as I believe it’s an antivirus issue, my computer is flagging these files as suspicious so locking them into read only mode - though cannot find McNeel or Rhino in the list of apps and therefore cannot add to list.

I’m having this problem now in Rhino 8. Can save as another file name, but can’t save file, nor can I overwrite existing.

1 Like

Me too… Win 11, newest update.