Display bug

I left my machine for a few minutes and came back and this model has a load of weird display errors. What the hell is going on? Is there a way to correct it or do I need to revert to a backup?

Update: I restarted my Mac and it seems to be resolved. Really weird though. I guess it is system related rather than Rhino related. I’ve never seen anything like it though.

Is this an older Mac with an Nvidia display adapter?

There are two Mac graphics driver bugs that I know of that can cause that.

  • this can happen with models that have clipping planes
  • this can happen when tessellation shaders are used

The OpenGL tessellation shaders on Mac never worked all that well. You can disable this feature in the OpenGL preferences for Mac.

1 Like

It’s a 16" MacBook Pro with AMD 5500M.

It could have been either of these things. I have turned off the OpenGL tessellation, but can’t really do without the clipping planes. I guess if it happens again, at least I know I just need to restart.

Thanks for the tips.

Unfortunately there is little we can do about this either. I have worked around the bug in a few specific cases, but it is difficult to repeat and fix.

This has happened again on a different file this time.

Make sure to disable tessellation shader use in the OpenGL preferences if you haven’t done so already

Thanks, it’s already turned off.

Are there clipping planes in that model? That’s the other spot I’ve seen this happen

Yes, both times I’ve seen this occur are with clipping planes. I can’t recall if the clipping planes were active at the time or not either time. I’ll pay attention next time

I get this issue, and it doesn’t help to turn the OpenGL tessellation off. I can’t use clipping plane in any models, it’s get very glitchy all over. Anyone know if there is any work around, or do I need to do a system upgrade / return to rhino 5? I have a 2015 mbp with Intel Iris Pro 1536 MB graphics card.


I’ve found that restarting my Mac makes things ok again when this glitch occurs. Makes me think that whatever is causing it, is causing some kind of persistent glitch or bug in the GPU.

If that doesn’t help, I don’t know what to suggest.

Thanks, I’ve tried, and it seems to be consistent with and without tessellation, before and after system restarts. Even if I make a new, clean empty file and put a single simple box into it, weird lines appear all over.

That sounds much worse than I’ve experienced. For me it is intermittent. Perhaps your situation might help Mcneel to identify what the cause is @stevebaer

@enric recently worked on a display driver bug that looks awful similar to this. I believe he added a workaround to the 7.5 release candidate, but he would know for sure.

If you haven’t, try the 7.5 release candidate to see if this fixes the bug

Hi @stevebaer,

The bug that I fixed was included in Rhino 7.4:
R̶H̶-̶6̶2̶6̶5̶0̶: Display: Clipping Plane issue with AMD Radeon Pro 5600M

AFAIK, the bug only affected MacBook Pro 16" computers with a Radeon Pro 5300M / 5500M / 5600M discrete GPU, running Windows 10 on BootCamp. @h11’s computer has an Intel Iris Pro GPU.

One possibility is that my fix has introduced a new bug on other systems. I think @jeff disabled my fix on Rhino 7 for Mac a couple of days ago.

@h11 When did you start seeing these clipping plane glitches?


The problem I have is with Rhino for Mac on my MacBook Pro with the 5500M. I don’t use boot camp.

I haven’t seen it for a couple of weeks though but then I’ve not been doing much rhino work. I think it last happened for me about a month ago.

These symptoms and problems are exactly why I disabled Enric’s “fix” on Mac OS…

Please get the latest 7.5 MacRhino, and let us know if you still see this.


These problems existing long before 7, let alone 7.4.