Rhino not detecting driver i think

Microsoft Corporation
GDI Generic
OpenGL version: 1.1.0
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA

Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32bits
Stencil depth: 8bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 0 MB

how can i solve this problem?

Please post the entire output of SystemInfo…

you can see how pixelated the view is

Yes you have no OpenGl driver.

Run SystemInfo and post the results, as asked before.

1 Like

they mean to type “SystemInfo” in the rhino command line, and paste the results that it shows

1 Like

The Rhino SystemInfo command won’t see anything else that’s useful.
Windows is not using the right driver for your gpu(s).
Basically, your computer is not setup correctly.

Instead, please run the Windows Device Manager and expand the Display adapters section.
A screenshot of that would help.

Screenshot 2023-04-17 003333

This problem happens every time I come back home when I’m at campus everything works just fine maybe it is the way I’m setting up the pc here at home I think.

If it were me, I would run the Windows Check for Update command.
Download and install everything, reboot, and run Check for Updates again.
Keep repeating until Windows says it’s fully up to date.

Are you connected to some sort of docking device?
If so, try disconnecting from that and restart.

My guess is then the Display adapters will show an Intel CPU.

That would indicate this is a Hybrid computer.
These instructions will help sort out that mess:

Thank you