Rhino Lockout

unhandled

#1

Hello all,

I seem to have been partially locked out of Rhino, I can move about still and rotate views. but I cannot enter any commands, I can’t open up the Rhino options or anything. The cursor seems to be locked to the one below, I can right click layers and select objects but not in any of the viewports.

It seems as if Rhino is stuck in a command, but nothing is running, The biggest worry is that I have made a lot of progress on this file and it locked up when I tried to save it - the file size in explorer is still the same as it was before and I’ve brought in a lot of geometry so it should have been a fairly dramatic increase.

Space, Esc and Enter do nothing at all.

I’ve tried running _Cancel, most commands will just give me the windows error tone as if I am locked out. I have VisualARQ and VRay running - is there anyway to unload plugins or to kill all processes sop to speak, I would really prefer not to have to force close the file, there’s too much to redo.

Alternatively is there any other way to diagnose what is going on here?

Thank you,

Sash


(Pascal Golay) #2

Hi Sash - does the command line say anything? Is there a dialog someplace off screen or behind the Rhino window?

-Pascal


#3

Hi Pascal,

Thank you for your constant vigilance on the forums!

The command line updates with whatever command I run, plays the windows error tone and does nothing. If I right click a layer and choose Select Objects it reads off the info on the objects but I can’t do anything with them. Ctrl+A also seems to select everything but again I can’t do anything with them or even deselect them afterwards

I don’t see any windows floating anywhere or any dialog boxes - is there any secret techniques I might be missing to bring any hidden windows up?

Also the amount of memory consumed by Rhino seems to be steadily going up and I am a little concern that in a few hours it will run out of memory and crash for good.

-Sash


(Pascal Golay) #4

Hi Sash - I am not very optimistic… Alt-Tab a few times to see if anything comes in front of the Rhino Window that you can use. You may just have to kill this…

-Pascal


#5

Alright, that’s pretty depressing, I’ve tried Alt+tab, cascading the windows and showing them side by side etc, nothing seems to come up.

What is a little strange is a bit before the crash I did close grasshopper and in the alt+tab dialog it still comes up as a preview, (you can see the compnents and wires faintly behind the dialog) - I didn’t get to run unloadplugin and now it seems I won’t get the chance to, unless is there a way to find grasshopper as it’s own process or service in task manager and kill it there?

image

-Sash


(Pascal Golay) #6

Hi Sash - I’m sorry… One thing I noticed just now testing after your GH comment is that I can see V6 and separately, Rhino Python that I had open in Task Manager. Once I opened GH, the Rhino 6 entry in Task manager still shows an arrow to expand, which pivots down when I click it, but nothing is shown below any more. I don’t know if that has anything to do with anything but it looks slightly suspicious to me… I shall dig into that but for now, I’m not sure what can be done.

-Pascal


#7

Alright, well thank you anyway,

I noticed that Escape and Space did nothing, however Enter would trigger the Windows Error tone.

A series of random key presses showed me that the shortcuts were still working, similar to how Ctrl+A still selected all objects, I could undo view changes with Home, and though it seems that it has crashed Rhino out for good, what it also did is reveal what I think must have been the offending process because Vray for Rhino appeared as an unresponsive program under the Applications tab, despite the fact that it wasn’t there, while Rhino retained some functionality.

A friend of mine recently had a similar issue and they had to force quit it, but I am pretty sure that they don’t have Vray and definitely not a Grasshopper user so perhaps there’s something else going on underneath it all?

Either way, the crash finally unfroze enough to generate an error report, so I hope that helps you guys glean some info about the issue.

Anyway thank you for your help as always.

Best,

Sash


#8

Over here many times when Rhino crashes with Error Report submission, there is a CrashDump.3dm file on the desktop that can be opened and shows the state from before the crash. Did you look on your desktop for it?
Small chance, but asking just in case…

–jarek


#9

Good shout Jarek,

I completely forgot about the CrashDump, but yes looks like it generated one at the time of the error report with all of the progress retained, I feel like Sisyphus standing on top of the mountain with the boulder next to him!

Many thanks

-Sash

EDIT: well almost, all the plugin data from both VRay and VisualARQ seems to have been wiped


#10

Great. Don’t let the rock slide.