Rhino Lagging with strong PC - Settings?

Dear Community,

I wanted to reach out and ask if someone might know a few settings to optimise modelling with Rhino.

I just built a new PC, with a 32Core AMD Chip and the fastest SSD available. Paired with a 2070 Super NVIDIA graphics-card and lots of fancy high performance components. Rendering works very fast, however the modelling seems unusual slow and none of the available resources seem to be used.

Any Ideas? Really appreciate some insights.
Best regards in the meantime, Aria

Hi Aria,

Good starting point is to run the command SystemInfo and.
paste the resulting report text here to give insight in the system Rhino is working with.

In the meantime: are all your drivers and is Rhino up to date?


Dear Willem,
thank you very much for responding this quickly!
I think I have found the issue, its when the Vray plugin is activated it seems to slow down the viewport and the interface dramatically. I reinstalled Rhino and Vray, but seems to occur again. I even downloaded an older Vray to see if this happens too and it does.

I updated the Nvidia driver too and restored all the graphic-card setting to default again.

Uninstalling or deactivating Vray does the trick. But in the same time, I need Vray for my everyday work. Is this a common problem?

Best regards and thank you for your time already :slight_smile:

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Educational, build 2020-08-25
License details: Cloud Zoo. In use by: Aria

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: DESKTOP-0H18MQ7

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 SUPER (NVidia) Memory: 8GB, Driver date: 8-12-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.06

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-12-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Aria,

As you have pinpointed the problem to Vray, it would be best to check the Chaos Group forum for possible causes and solution.
As stated in this post:

Maybe someone at McNeel will chime in here as well, or try to crte a new topic at

Good luck

Dear Willem,

thanks for your response again! I didnt hear back from ChaosGroup yet and left them a two messages. Any Ideas what the issue might be about?

Thanks again,
best regards in the meantime!


I’m out of ideas unfortunately…