Lag at the render viewport

Good evening,
I have noticed that there are too many delays when processing a model in render viewport

Hi Πέτρος -

Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino 7 SR29 2023-4-17 (Rhino 7, 7.29.23107.03001, Git hash:master @ 5f05ef3a2eea3d910c4c2fb79ccc75b413d33ca7)
License type: Evaluation, build 2023-04-17
License details: Cloud Zoo
Expires on: 2023-08-23

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3080 (NVidia) Memory: 10GB, Driver date: 5-24-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 535.98
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-24-2023
Driver Version: 31.0.15.3598
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 10 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Thanks, that looks fine.
When you create a simple box in a new file from a factory-default template, do you notice “too many delays” in the render viewport?
Also, what does “render viewport” mean to you? Is that the factory-default “Rendered” display mode?
-wim

I have made a model which is not simple. It has many details and many surfaces. I have added materials from V-ray and when I choose PERSPECTIVE VIEW with rendered display the mouse movements lags too much … i can’t zoom, i can’t rotate the object. Ηowever when I return to shaded display movements are carried out without any delay.

Hi -
What happens when you disable the V-Ray plug-in in the plug-in manager and restart Rhino? Does the behavior change?
-wim

I disabled every material I had placed on the item. His behavior is a little better. I’m handling the object a bit better, but there’s still a lot of movement lag

Hi Πέτρος -

My question was what happens when you disable the V-Ray plug-in.
-wim

explain me how to do this action

In Rhino, run the PlugInManager command.
Look for V-Ray in the list - you can change the pull-down menu to only display plug-ins that do not ship with Rhino to make it easier to find:
image
Uncheck the plug-in in the “Enabled” column and restart Rhino.
-wim

disable what I have highlighted. Right ?

I’ve never used V-Ray but it looks like there are two plug-ins that include that name. You’d want to disable both to make sure…
-wim

if I deactivate them, will I be able to activate them again if they are useful to me?

I turned them off and it lags too much again

apart from the very long delays caused by the model when zooming and also during its rotation there is still a problem with the projection of the lines as I show in the image below. I don’t know what’s going on and I need help with both my 2 issues