Nvidia GeForce GTX 960M Slow performance on performance laptop

unhandled

(Albert Abrahamsson) #1

Hi, I am experiencing extreme lag in Rhino when modelling even the most simple geometries.

My system is as follows:
Windows 10 PRO (1709) 64-bit
i7 6700 HQ 2.60 GHz
32 GB RAM
Nvidia GeForce GTX 960M 2048.0 MB
DriverVersion: 23.21.13.9077

Why cant I even barely navigate a model without experiencing extreme lag?

Rhino won’t recognize my driver version or date in OpenGL settings.

WHAT AM I NOT GETTING?


#2

I guess you have a dual card setup, so check in the nvidia drivers and see if you can “force” it to use the nvidia card for Rhino. It should be good and strong.


(Albert Abrahamsson) #3

Indeed it is a dual card setup, but have set it to use the Nvidia GPU already, tried to fiddle with settings and so on. I have experienced some lag in very large files before, but since latest windows update the lag is just simply unbarable. Will try to copy everything into a new file, see if it works.

I have made a clean install of Rhino 5 and rebooted computer several times since upgrading to latest nvidia drivers.

Nvidia also displays that Video memory is limited to 64 MB.

And task manager shows that only 5-12% of the GPU is used. WHY?!?!


(Nathan 'jesterKing' Letwory) #4

Have you tried with (evaluation) Rhino 6 yet?


(Albert Abrahamsson) #5

A while back, but it is expired now, That worked very well.
It might be that i have a very high DPI on my monitor, but even on external monitors it rund very slow.

Sometimes shaded views are faster than wireframe view, but all are very slow!


(Albert Abrahamsson) #6

Tried runnng the 32 bit version, and it seems to perform better, which shouldnt be true?


(Albert Abrahamsson) #7

I did hide a block instance, and performed a clean install of the video card driver. Now it works a bit better, Also tweaked the nVidia settings acording to some guide I found.

Seems to have helped and it utilizes more of the GPU. Seems like I had a Block in the file that slowed down the software tremendously. weird… Still wont recognize the driver and video memory size though.

Still not all resolved.


(David Eränen) #8

Hi @albert.abrahamsson ,

I suspect Rhino is using the integrated Intel GPU, and not the NVIDIA one.

Could you go to NVIDIA Control Settings -> Manage 3D settings -> Select a program to customize: “Robert McNeel & Associates (Rhinoceros NURBS modeler)”.

Select the preferred graphics processor: High-performance NVIDIA processor.

If the option above is not available, then look for “OpenGL rendering GPU” and select your NVIDIA GPU in the drop-down list.

Any luck?

-David


dGPU and iGPU clashing with each other when multiple monitors are connected
(Albert Abrahamsson) #9

These are my current settings, (sorry for the swedish) It definately runs on the right GPU, but s soon as i have a block imported from *.STEp or *.IGES and I monitor the activities in task manager, I see that it only utilizes maximum 12% of the GPU. It might be some kind of multi-thread GPU calculation issues when I have a block in the viewport.

I have made a clean install of the GPU drivers and it made a remarkable difference, but still not as good as I would believe the machine is capable of. Wireframe is really slow, shaded modes are quicker!


(David Eränen) #10

Inga problem, här kan vi nog svenska! :wink:

Har du GPU tessellation ikruxat på Tools -> Options -> View -> OpenGL ?

-David


(David Eränen) #11

Could you send us the file so that we could see if the problem is mainly in the model or something else?

If you want to send it privately do it via here: https://www.rhino3d.com/upload

Put my e-mail as the recipient: david.eranen@mcneel.com

-David


(Steve Baer) #12

Windows treats 32 bit applications in a legacy mode which can in some cases be more efficient for display speed. This is because the application is given lower resolution windows to draw to in high DPI situations and the windows performs the appropriate stretching to draw onto a higher dpi screen. This also means the application can’t really take advantage of high dpi drawing. Another reason could be that the 32 bit version of a display driver outperforms it’s 64 bit counterpart.

Rhino 6 should perform a lot better. Based on your comments, my guess is that one of the blocks you are importing is actually quite heavy. David can probably give you a better answer if you send him a model.