Rhino is not supported on Windows Server-But i am running Win 10 Pro

after years of using Rhinoceros 3D a am suddenly confrontet with an error at startup.
it says:
Rhino is not supported on Windows server.

Capture_rhino error

I do not run a Windows Server version as far as i know.
can anyone help?


This ist the device i am using:

Thanks in advance,

Windows 10 Pro Version 2004

That’s an old, unupdated version of windows 10 from 2020… the current version is 21H2.

Apparently no longer supported by Microsoft as of 21 December 2021…

Maybe that is the problem?

thanks for that quick response @Helvetosaur !

i removed the latest updates from my OS thinking the bug was there.
now just updatet to 21h2:


i still get that errror

Addition: Rhino 8 WIP seems to get that same error while Rhino 6 launches smoothly.

The message above in the first post seems related to Rhino.Compute… Are you doing anything with that?

No, at least i am not aware of that.
Somehow Rhino considers my OS to be the server version.

Bizarre. I seem to recall something like this a long time ago, but I can’t find anything in a quick search… @wim - do you have any idea?

I believe it’s related to feature pack.

Sort of bugs in Rhino

hi @gankeyu,
some feature pack of Rhino?
how could this be bypassed?

No the windows experience program thing… we’re totally just guessing here but that may be flagging it as a non commercial Windows. Are you a developer with a msdn subscription? Did you get Windows from a sketchy source for a stupid low price?

It’s unrelated to licensing. It’s merely a shell add on. It’s very likely Rhino checks OS by WMI or similar hard coded ProductType in registry and mess up something.

I presume this is the first time you’ve run Rhino 7 on your computer? Do you have the latest Rhino 7.17 installed?

Are you running Windows 10 as part of a virtualized desktop setup? Are you running in Docker?

I’m grasping at straws here, because Rhino generally detects the OS correctly.

am neither running a Win 10 version from a shady source nor is it the first time running rhino 7. Yes i just reinstalled Rhino again.
I am also working with a one Person setup on my worstation, no virtual machines no remote Desktops.
Rhino has bin running flawless on my pc since a few years.

Hi Ivo -

Do you know what has changed on your system that might have caused this sudden change?

Hi @ivo_Pass,

If you run
wmic.exe os get producttype
in Windows Powershell, what number does it return? (ignore any message about wmic being deprecated).

it returns 1

That means the Windows Management Information subsystem is reporting it as a Workstation, not a Server. I believe WMI is the approved route for applications to get information like this. I wonder how Rhino does it? @brian ?

Uhh, one delicate question @ivo_Pass, pertinent to asking Brian about this so please don’t take offence, but I take it you have a legitimate copy of Rhino, not a cracked version?

i thougt of any automatic os updates and removed the ones from the last few weeks. with no effect.

i currently use a testversion from rhino3d.com

Which version?

Runs the Rhino 7 command SystemInfo and post the results here.