Rhino Inside Revit Multi Floor Creation

I’m trying to solve a mystery with floor creation using grasshopper.

I’ve got about 40 closed, planar crvs in rhino, and using the “add floor” with boundary component in grasshopper, it simply refused to make them all at once. But, for whatever reason, it let’s me do it one at a time.

Anyone have any ideas? Does the curve type matter?

Is the list Grafted? can you post an screenshot towards the end of your definition?

I attempted to graft the list, and this did not change the outcome. Let me grab a screen shot. It’s really not a complicated script.

I noticed once I did them individually, a few of them broke.

Follow up because I think I “might” have figured it out. Revit handles splines horribly and I think this is the case here. While the curves are based on a series of arcs, it looks like somewhere in the script they are being converted to splines. Sigh.

definitely the curves, grafted or not it still makes one floor per curve.

Hi @bejathen,

May I have access to those curves?
Maybe there is a problem in our side that needs to be fixed.

Has this problem been solved?
I’m having this problem trying to build multiple floors with curves.

If i feed the component with everything the floors are invalid and are not created.

But if i feed the component with just one curve listed, it builds that one.

Then i tried list the curves with a series and they get built but if increase more numbers, some floors begin to fail.

Later, i tried again this last strategy but somehow now it wont build anything.

I have revit 2020 and the rhino 7 trial license.

I’ll add the curves internalized that i’ve been using
curves.gh (9.4 KB)

Definitely forgot I submitted this. I ended up building it manually in Revit. I think there’s something super specific with how the base geometry is built that converts from arc to spline and that’s what was causing the script to break.

One thing I would consider is if a couple of the curves cause the script to break (maybe test one by one). I have similar problems when I try to bake certain geometry into Revit.

curves.gh was blank, please internalize your curves again and we’ll take a look. Thanks.


I just edited the question and update the gh file. Sorry :sweat_smile:

The issue is your curves are really small. I have scaled them 1000 times and grafted the list. it generated floors just fine.

curves_grafted and scaled.gh (16.6 KB)

Hey thank you.

But my rhino file is in meters. Am i doing something wrong in my model?

You have two curves slightly out of plane. Depending on how your Rhino Units are set its hard to see.


A quick fix in Rhino is to use the SetPt command and use Z only. Setting your Cplane (set C-Plane by Z-Axis) to the exact Z you are looking for (getting rid of the float)

There are a few ways to get things planar in grasshopper as well, but to ensure the Z is correct I would do the fix in rhino.

1 Like

I got those curves taking the faces looking up of every “slab” layer in gh to build the floors on revit.

Do you thing this have to do with the absolute tolerence of the model?
I mean, i would thing this pieces are planar because i used boxes. But i’m not sure if something else is coming up in the middle of it.

Yes, with the tolerances set low [.01] IsPlanar component in GH will show true, but the reality is .0000005 off which was causing the issue.

Revit used to open Rhino with Default units set to 0.0005233832795 feet or 0.000159527224 m respectively, not sure why that changed.

1 Like

Silly me. My revit was in millimeters :slight_smile:

1 Like

Don’t worry, this stay between us… and the whole rhino.inside forum