Rhino/Grasshopper forcing Computer Restart

Lately, when running some grasshopper scripts, it shuts down and restarts my computer (once it even caused both rhino & gh files to revert to a much earlier state despite saving), and I don’t know why. The scripts aren’t egregiously heavy and my computer is pretty robust, but I’m not very computer savvy so I don’t know if it could be a hardware issue instead (though it seems restricted to rhino/gh). Anybody else having this problem or suggestions for how to determine cause?

Rhino 7
Windows 10
Intel i9-9920x
X299 Designare motherboard
Corsair Dominator Platinum (8x16 GB) DDR-4 CL 16 Memory
Samsung 970 evo 2TB SSD
NVIDIA GeForce RTX 2080 Ti 11GB
Corsair HX 1000 Platinum


Brian B

Hi -

I don’t know if that is intentional, but that sounds like the behavior is specifically related to a few Grasshopper files. If that is the case, please post such file.
Apart from that, when providing your system information, please run the Rhino SystemInfo command and copy-paste the result here.

hi wim, thanks for the response.

i mean, maybe, but since gh is integrated in rhino 7 i wouldn’t know where the issue is. but the scripts that have caused crashes aren’t always related, but i’ll try to provide one later. for now the system info is:

Rhino 7 SR12 2021-11-2 (Rhino 7, 7.12.21306.15001, Git hash:master @ 5b29f2d5cf917d92f3e5e04559fbfbfdd15696ac)

License type: Commercial, build 2021-11-02

License details: Stand-Alone

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 1.3e+02Gb)

Computer platform: DESKTOP

Standard graphics configuration.

Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 9-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.12

Accelerated graphics device with 4 adapter port(s)

  • Windows Main Display attached to adapter port #0

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 9-13-2021

Driver Version:

Maximum Texture size: 32768 x 32768

Z-Buffer depth: 24 bits

Maximum Viewport size: 32768 x 32768

Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino

C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp “bullant”

C:\Users\bdb\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\TeDAsharp (ce983e9d-72de-4a79-8832-7c374e6e26de)\1.0.6981.15425\TeDaSharp.rhp “TeDAsharp” 1.0.6981.15425

C:\Program Files (x86)\Evolute\EvoluteTools LITE for Rhino 6\EvoluteCoutHook.rhp “EvoluteCoutHook”

C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino

C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21306.15001

C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”

C:\Program Files\Rhino 7\Plug-ins\export_OBJ.rhp “export_OBJ” 7.12.21306.15001

C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21306.15001

C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21306.15001

C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Users\bdb\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2020.12.9.865\PanelingTools.rhp “PanelingTools”

C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.12.21306.15001

C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21306.15001

C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.12.21306.15001

C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21306.15001

C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”


Hi -

Thanks for the system info. You have a few none-default Rhino plug-ins but since it’s a Grasshopper definition that causes the reboot, those might be fine.
We’ll need a Grasshopper definition that reproduces the crash.

I had such cases rendering wence my cpu/GPU was clogged with dust…
if that helps. Renewed PC is much sturdier and cleaner… No more crashes…

helped to find the cause…