(Solved: Parallel computing setting) Unknown full crash caused by something in a Grasshopper definition

Grasshopper definition crashes Rhino without showing any pointers.
I have tried to deactivate parts of the scripts and that will make it run again, but can’t id the specific problem.

CrashDump in attached zip-file.

RhinoCrashDump.zip (15.7 MB)

A couple of follow-up observations:

  • Deactivating the whole script and then meticulously enabeling it step-by-step works and it computes to the end where it would crash somewhere unknown before.
  • Right before it crashes the Task Manager shows Rhino 6 as suspended like so: image

Hi Morten - can you send us the GH definition and a file that will allow us to repeat the crash? Either here or to tech@mcneel.com (if confidential). Please include a link to this thread.



Hi Pascal

I have sent an e-mail with the files to support and tech, to also follow up on the two error reports that i did manage to extract yesterday.

Best Morten

Just an update to close this. It turned out to bee related to the “Parallel computing” setting on a couple of intersection components. Turning this of solved the issue.