Rhino, Grasshopper for Mac constantly crashing

The crashes started happening 9 months ago and had gotten to the point where the computer would crash after 10 minutes of turning on the computer even when I do not open Rhino. Mac wiped the computer and reinstalled MacOS and did not find any hardware problems. Everything worked fine for a few weeks but now Rhino crashes every time I save in grasshopper as well as other random times. The random Rhino crashes seem to be getting more frequent. Help please!

MacOS Mojave 10.14.1
3.2 GHz Intel Core i5
8 GB 1600 MHz DDR3
NVIDIA GeForce GT 755M 1024 MB
Late 2013 iMac

Can you please provide some additional information? Please navigate to Rhinoceros > About Rhinoceros > More Info > Copy to clipboard and paste the information back in here?

In order to address the problem, we need to be able to reproduce it on our end, so any steps you can provide (small details often matter) to help us see what you are seeing are appreciated.

One other question: have you tried the Grasshopper in the latest RhinoWIP? I would be curious to hear if it is more stable or not.

Thanks for your reply. Here is the info.

Software information

Software versions
Rhinoceros version: 5.5.2 (5F85)
Rhinoceros path: /Applications/Rhinoceros.app
IronPython version: not installed
Language: en-US (MacOS default)
macOS version: Version 10.14.1 (Build 18B75)


Third party kernel extensions

Hardware information

Computer hardware
Hardware model: iMac14,2
Processor: Intel Core i5-4570 CPU @ 3.20GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 755M 1024 MB
Memory: 1024 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
Apple: Apple Wireless Keyboard
Apple: Apple Magic Mouse

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-12.0.19 355.
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

The latest crash happened using grasshopper. The last thing I did was to load new images into an image sampler. The crash was not immediate, but a minute later. This also happens anytime I save grasshopper.

I have not tried the latest RhinoWIP, but I will give that a shot.

Thanks for the System Information. I don’t see any red-flags there.

This also happens anytime I save grasshopper.

I’m definitely not able to reproduce this.

I am curious to hear if it is better with the RhinoWIP.