Grasshopper crashes when

I found interesting crash. When I run Grasshopper and use some geometry tools (circle, curve etc) by dragging them onto canvas Rhino always crashes. But when I do this action by clicking on tool icon and on canvas everything works correctly. This problem was found at MacBook Pro 2018(Mojave) and at MacBook Pro Early 2015(Mojave). But at MakBook Pro 2011(Sierra) this problem does not exist.

How can I аix this problem?


Software information

Software versions
Rhinoceros version: 5.4.1 (5E409)
Rhinoceros path: /Applications/
IronPython version: not installed
Language: ru-RU (MacOS default)
macOS version: Version 10.14.3 (Build 18D109)


Third party kernel extensions

Hardware information

Computer hardware
Hardware model: MacBookPro12,1
Processor: Intel Core i5-5257U CPU @ 2.70GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris Graphics 6100 1536 MB
Memory: 1536 MB
Screen size: 1280 x 800
Displays: Color LCD (227dpi 2x)

USB devices
Broadcom Corp.: Bluetooth USB Host Controller

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-12.4.7
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Hello @diger499,

First of all welcome!

Have you tried updating Rhino to the latest macOS version, which is 5.5.3?
Your posted log indicates that you’re still using 5.4.1.

I’m only guessing, but I’d say that your current version isn’t fit for running bug free on Mojave.

Thank you!
Indeed, after update everything works correctly.

1 Like