Rhino/GH is not using GPU for new plug in tOpos

Hi world,

I have a quite precise and problematic issue. I’m trying to use this new plug in for topology optimization called tOpos (https://www.food4rhino.com/app/topos). A friend told me is working very well. It’s like Millipede but it is using GPU for the calcula, should be 100x time faster.

BUT I’m having a problem with the example file. It gives me this message. (attached png)

Seems that Rhino/GH is not looking of my GPU (GeForce GTX 1060) but to my intel basic GPU (I have a Dell inspiron 15 7000 Gaming). I think is because of some settings of Rhino/GH/tOpos/NVIDIA, cause my friend is using it and it works very well.

I’ve tried several things but none worked.

Thanks for the help boys :slight_smile:

Michele.

Michele. Hi. Have you found any answer to this? I think I have the same problem. I got this error as well:

Object: tOposCudaCtx (level 1)
{
Se produjo una excepción en el destino de la invocación.
TargetInvocationException
}

Object: tOposCudaCtx (level 2)
{
Se produjo una excepción en el inicializador de tipo de ‘tOposCore.CoreGPU’.
TypeInitializationException
}

Object: tOposCudaCtx (level 3)
{
Referencia a objeto no establecida como instancia de un objeto.
NullReferenceException
}

I had the same issue and got it to work. In the comments on Food4Rhino someone posted a solution:

  1. Right click on “CudaContext” switch from Auto mode to your GPU

  2. Right click “Optimus” change to “PreAssemble Solver”

  3. Hit Run!

Lee_Souder on Fri, 08/02/2019 - 07:50

Louis. Hi.

Thank you for the help. I tried to install and run the algorithm and the plug in in another computer. The plug in is complete in there and that pc is like 5 or 6 years old.

The thing is that I cannot run it on my desktop and the error that comes out is this one:
Object: tOposCudaCtx (level 1)
{
Se produjo una excepción en el destino de la invocación.
TargetInvocationException
}

Object: tOposCudaCtx (level 2)
{
Se produjo una excepción en el inicializador de tipo de ‘tOposCore.CoreGPU’.
TypeInitializationException
}

Object: tOposCudaCtx (level 3)
{
Referencia a objeto no establecida como instancia de un objeto.
NullReferenceException
}

Do you have any idea of what may be happening? It could be my drivers, but I updated yesterday before installing it.

Where are you getting that info, in the Rhino command line?

Have you unblocked the files before copying them to your Grasshopper components folder?

https://wiki.mcneel.com/rhino/unblockplugin

Louis. Hi.

Actually there was no need to unblock. The files came without the option of “unblock” in the properties menu.

Im sending you a screenshot. It comes out right after the loading of the grasshopper and its plug ins.

And when that happens, the component caled “Cuda Context” doesn’t appear on the tOpos menu. Captura

I am having the same issue. Is there any update regarding this problem?

Hi, sorry for the late reply. I’ve found no solution at this topic unfortunately :frowning: I’ve tried to write to the developer too but no reply.
On my old and less powerful PC topOs is working and I have no clue why.

Some updates?

@Louis_Leblanc thanks but I’ve seen it too… it’s not working

I am not the developer, but check what NVidia driver you have and up until what version of CUDA it works with, and compare it to what CUDA version tOpos is built on.

Anyone had any progress? I am having the same problem. My CUDA version below:

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2019 NVIDIA Corporation
Built on Sun_Jul_28_19:12:52_Pacific_Daylight_Time_2019
Cuda compilation tools, release 10.1, V10.1.243

Is it too recent for tOpos? Which cuda version is it built upon?

Thanks

The description says that tOpos is built for higher or equal to CUDA 3.0.

In my case, I’m not able to run this with my desktop that has a GTX1060, but Im able to run it with my old laptop that has a Geforce 745 M

Im as lost as you. All the simulations, although I’m able to run them, are not as fast as I could handle them on my bigger pc.

Its kinda sad that this plug in is not being updated, or at least having a response from the developer.

I’m trying to make a manual for myself in order to control it as it is and as we have it.

Thanks for replying Roberto. Hopefully the developer will get a bit more active, highly unlikely though…

@Louis_Leblanc answer was great, it helped me get it moving, but it only uses 1-5% of my GPU.

It looks like this plugin has really great potential.

I’ve been wondering if it’s possible someone else take on managing the plugin? And also, any thoughts on how much work it would take to implement the latest versions of CUDA?

(I’m hoping the answers are Yes, and not much…)

Any suggestions?