Rhino freezes my screen

I am having problems with Rhino 7. Whenever I start working in my file, which is only 4 mb, my screen freezes after about 2 min and I have to restart my computer, which has happened about 10 times today. I have tried reinstalling rhino, updating my graphic card automatically from the device manager and manually by downloading it, which didn’t work. In Rhino notifications it still says video drive update recommended. Also copy pasting the content into a new file, did not work. Whenever i open a clean file in Rhino the problem does not occur.

Hope that somebody can help me, I am running out of ideas :sleeping:

Bonus info: I am doing an online internship and i have google meets running in the background. The problem seems to be lying in a combination between the file and the video call, also when i turn off my camera.

system info:
Rhino 7 SR3 2021-2-8 (Rhino 7, 7.3.21039.11201, Git hash:master @ 7bcc02a54515376cb2bd3d05f62d9473ab4bc38c)
License type: Evaluation, build 2021-02-08
License details: Cloud Zoo
Expires on: 2021-03-13

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [93% battery remaining] ~441 minutes left

Standard graphics configuration.
Primary display and OpenGL: Intel® UHD Graphics (Intel) Memory: 1GB, Driver date: 10-12-2020 (M-D-Y). OpenGL Ver: 4.6.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 10-12-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi @katjakajkaj
I would try and disable Vray in the PluginManager first, restart Rhino and see if that helps.I don’t use Vray myself, but it comes up quite often as the reason for crashes - especially on under-powered hardware (that Intel graphics chip of yours is not really suitable for Rhino 7, to be honest).
HTH, Jakob

your machine does not meet the min requirements for rhino- we ask for 4gb viram minimum per monitor. If you are running two monitors you will want 8gb vram, your machine only has 1gb. Also Intel video is well known to be less than desirable for open gl performance.

you will want to disable hardware acceleration in your advanced options to have any chance of running on this machine.

change this setting and restart rhino. It will look awful, but run better.