Rhino for Mac can not find the materials anymore

Hi Experts,

I have a Problem.
I have been trying to use the (provided) materials within the rhino renderer…
But for some reason in the rendering view all I have on my objects are grey surfaces with the wording “rhino can not find the Material named…” on it.
Why is this? where did the materials go? ^^
I even uninstalled and reinstalled rhino…but still the same issue.

Thanks for your help!

I changed the category to Rhino for Mac as this concerns the Rhino renderer and I think it more likely to get a response in the general category.
-Willem

Are you using Rhino in a language other than English? If so, this is a known bug (MR-2160) that we are working on a fix.

Hey,

Thanks for the reply!
Yes, I am using a German version. When would this problem be taken care of then? Or ist there another quick fix solution like a free materials download package…apart from having to create all the materials from scratch?

Cheers!

Soon. A fix for this will make its way into the next major 5.1 update. That said…

Or is there another quick fix solution like a free materials download package…

There’s a workaround for this annoying bug*. Rhino is looking for the German texture name in the English folder and not finding it. You need to “Choose” the texture image manually. Update: See below. Let me illustrate the workaround (I’ll use the English material names, so translate these in your head, please):

  1. Open the Material Editor. Find click on the material whose texture is not working. You should see it’s properties appear in the panel below:
  2. I’m using “Hammered” as an example. (Rhino will find the texture map for me, because I’m using it in English.) Scroll down into the Texture section and expand it (if necessary).
  3. Click on the Map file: drop down and select Choose
  4. A file browser window opens. I suspect this will be pointing to the /Applications/Rhinoceros.app/Contents/PlugIns/RhinoRenderV5.rhp/Contents/Resources/en.lproj/Render Content/Textures folder…
  5. It’s the en.lproj that is the problem*. Rhino is trying to find the texture.png for this texture (whatever “Hammered” is in German) in the wrong language.
  6. If you click on de.lproj three folders up, then drill down into Render Content/Textures you should find “Hammered” in there. Select that file.
  7. You will have to do the same thing with the bump texture (if applicable). The rest of the material settings should be appropriate and correct.

This is annoying, I know. I think we should store these files in a more sane location outside the Rhinoceros application bundle, such as in ~/Library/Application Support/McNeel/Rhinoceros/Render Content/Textures, as others have suggested. BUT we also have to fix this bug. It’s on our list (@marlin).

Hopefully this solves your problem. Sorry for the weird behavior. It’s only temporary.

-Dan


*the names of the textures that come with Rhino are translated into each language. The bug listed above is that the Rhino material editor is looking in the English folder for - in your case - the german file name and not finding it.

Hi Dan, been following this thread with interest - I’m having the same problem (my Rhino is in french).
When I get to step 3 the Rhino icon is greyed out and I can’t access it.

If I go through the finder, I get to the en.lproj folder but there is no Render Content folder…

Thanks.

Thanks for posting this!
For me it’s the same! I can not manually select the material…

I apologize. This is worse than I thought. I did not check the path correctly in my post above.

The path to the render content is:
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRenderV5.rhp/Contents/Resources/

…and, as you have discovered, using Rhino’s material editor to Browse to this location does not work. It also looks like the language-specific resources are aliases (symbolic links) back to the English content. That makes it harder to work-around.

Ok, as (yet another) temporary work-around, let’s try moving all this content outside of Rhino (for the moment)…

  1. Quit Rhino.
  2. Create folder called Resources on your Desktop.
  3. In Finder, navigate to Finder > Go > Go to Folder…
  4. Paste in this path: /Applications/Rhinoceros.app/Contents/PlugIns/RhinoRenderV5.rhp/Contents/Resources/ and press the Go button. A new Finder window should open in that folder.
  5. Find your language. (I’m going to use French as an example. fr.lproj is what I am looking for.)
  6. Hold down the option/alt key and drag the yourlanguage.lproj folder into the Resources folder you created on your Desktop in step 2 above.
  7. Hold down the option/alt key and drag the en.lproj folder into the Resources folder you created on your Desktop in step 2 above.
  8. Create a folder in your Documents folder called RhinoRender Temp (or similar). Really, you can put this wherever you feel it is convenient. I’m going to put this in /Users/dan/Documents/RhinoRender Temp.
  9. Move the Resources folder from your Desktop into this new location in step 8 above.
  10. Start Rhino. Open the Material Editor.
  11. Grab a material from the Standard Materials library (Matériaux standard for me), and drag it into your material library above (Matériaux personnalisés for me). I’ll grab Cerisier (Cherry). Apply the material to something in the model.
  12. Select the material from step 11 in the Materials in model area to edit it.
  13. Scroll down to the Textures section and Choose a new texture for the color channel.
  14. Now, you should be able to navigate to /Users/~/Documents/RhinoRender Temp/Resources/yourlanguage.lproj/Render Content/Textures/ and select the appropriate material (in my case, Cerisier.png).
  15. Apply this material to something in the model. It should work now.

We’re working on getting this fixed.
(cc @marlin)

Hi Dan,
I religiously followed your instructions - see screenshots - the problem here seems to be that the materials editor is looking for a *.png file and in the *.lproj folder there are only *.rtml files that I can’t select as they are greyed out but which show up fine in the finder!

PS I checked the other *.lproj folders as far as I can see they all contain *.rtml files

OK, done some more searching… the *png files are in -

the en.lproj folder in the textures folder, all the other language *.lproj contain aliases which don’t seem to be working.

After having moved the *png files to my RhinoRender Temp folder I now have textures!

I hope step 14 was clear on this, but it is crucial. Well, they were long-winded directions :wink: The worst kind. Keep in mind, some materials might have textures in other channels, such as Bump, Transparency, etc.

Sorry about the confusion.

I also could not seem to get any surface, other than the gray, when trying to do a render of an object in the purchased version of Rhino for Mac, English language version. Will this forum notify us when this bug is fixed?