Rhino doesnt start

i installed rhino on windows laptop (gaming beast). i am completely new to rhino and when i double click the icon, it doesnt respond at all. Could someone help with this issue? i managed to run rhino before on my laptop. now it doesnt start at all, not even an error message. so frustrating

The only possible way to turn on your rhino back is Uninstall & Reinstall. Try this.

Why are you sure he needs to uninstall and reinstall?

@davidcockey Even I faced this kind of issue. For me Uninstall/ Reinstall turns as a solution not now. A long back with my old PC. So I suggested it. Or else someone need to remotely control his PC and check error.

it didn’t work and only problem with rhino. no problem with running other modelling tools. before rhino was also working, i do not know what happened. i installed and uninstalled several times. please help.

Hi - have you tried running Rhino in Safe Mode?

Which version of Rhino?

I am trying to install 6.25.20114.05271, it is saying successfully installed but not starting at all, even tried in safe mode, nothing, i want to buy it but if this is the case then it is just wasting money.

the problem is rhino is not giving any error also, it is just not starting

This won’t fix it, but it should generate a file we can review to see where Rhino loading is failing: