Rhino display problem zoom in

I don’t know why my rhino model looks like they are cut by something?
When I zoom in, they will look like this, but when I zoom out, it becomes good view.

1 Like

Hi arc_​qiushi - do you have a large extent of the model behind the camera? Does the clipping stop if you set the viewport to use parallel projection (See Properties, with nothing selected to see or change the projection in the active viewport)

-Pascal

It is fine in any project views,like top,left,right…just in perspective, they looks like all broken.
Yes, I have bigger model in the background, even to look at the bigger model, they have the same problem.
I found when I use “zoom extent”, my whole model become very small in the screen, it seems there are more models in this file, but I can’t find them.

Hi Arc-qiushi - please try-

Zoom Extents so that the model is very small.
Make a very tight selection window around the model to select everything.
Type _Invert and

Does Rhino report anything as selected? If you delete or hide these objects, does the view behavior improve?

-Pascal

Hi Pascal,
I found when I close grasshopper, the zoom extents can make the model showed properly in the screen. So there must be some problem with the grasshopper file.

Hi arc-qiushi- to isolate the problem, you can try turning off the previews of the GH components until it behaves again.

-Pascal

Thank you Pascal!
I turned off the previews of all the GH components, but it still has this problem. The problem only disappears when I close the GH.

Hi Arc_qiushi - if you can reproduce this in a file that is not too massive, and that you can share with us, , can you please send to tech@mcneel.com? With the GH definition as well… I guess we should try to reproduce this here and see if there is something we can fix.

thanks,

-Pascal

This issue happened to me a lot in both cases. GH+Rhino will cause this problem for sure. Rhino itself sometime has the same problem. I need a set of time to report all of these.

-Kev

I have also this issue and I don’t use GH.

hi arc_quishi, that happened to me as well, its because you have more than one model in your rhino file, so the view gets confused when you zoom in and cuts the objects, the solution is to export the model your working on to a seperate page to have only one 3d model, and the problem will vanish.

Abbas