Rhino displacement tool

Is using the ApplyDisplacement tool buggy? Im trying to apply a noise texture to a surface but it keep saying displacement failed… I can appl it to say a plane, but im trying to use it on a surface that has been deformed using the cage tool… also if i try and trim the surface it then reverts back and doesnt show the applied noise

The displacement settings may require more memory than is allocated by default. Check the command line when it fails, does it say “mesh memory limit hit”. If so, up the amount of memory in the advanced settings>mesh memory limit. I generally don’t go above high. Most of the time resampling the source image is more useful than increasing the poly count.

Post a file and texture and I can take a look as well.

Where can I find advanced settings? I tried going to settings, view, rendered, objects, and mesh thinking that’s where it would be but couldn’t find it.

Select the mesh. Click Properties panel tab. (It is on the right side.) Click Displacement options icon. Advanced settings are at the bottom of the Properties panel. If there is nothing under the Advanced settings, click the Advanced settings.

Info about Panel options:

1 Like

Its possible change mesh memory limit from today maximum 8192 on 16384 MB?

as long as you have enough system RAM then yes.

On Rhino for mac. We have 64GB RAM on macbook and maximum is 8192.

Hi Peter -

That doesn’t appear to be possible, no. I’ve added your request to the list as RH-68551.

RH-68551 is fixed in the latest WIP

1 Like