Rhino auditing objects every single time I copy/paste

unhandled

#1

Hi!
As the title describes: this happens all the time and is very annoying. Is there any way to remedy this?


(Pascal Golay) #2

Hello - you may have CheckNewObjects running - try running that command and answer the question ‘Automatically check new objects?’ in the message box with ‘No’. Does that do anything good?

-Pascal


#3

Thanks for the quick reply! Unfortunately no luck with CheckNewObjects :-/


(Pascal Golay) #4

Hello - what is the message that you’re getting, exactly?

-Pascal


#5

Automatic checking is turned off.

When it occurs I get a percentage bar in the lower right corner saying “Auditing objects”


(Pascal Golay) #6

Hmmm - check if AuditAfterEveryCommand is set to Yes.

-Pascal


#7

“Postcommand audit is off”


(Pascal Golay) #8

Hello - I’m not sure then… maybe it is not Rhino… do you have any non-default plug-ins loading?

-Pascal


#9

I have a few, most are disabled… Ill reinstall the lot and see what happens. Thanks for helping out!


(Litwinaa) #10

Hello Pascal,
Where please do I find AuditAfterEveryCommand to set it to yes ? I have check New Objects running but I did a Split command on a piped object and it looks like this caused the introduction of two Naked edges into the split object. Check New objects did not alert me to this - if this is what it is supposed to do ?

Thank you, Andy


#11

This is not currently possible, although an extended user-configured object checking has been asked for in the past… Check only flags “bad” (invalid) objects by Rhino’s definition which generally means that the NURBS structure is not correct.

Naked edges are not considered defects as Rhino is a surface modeler. If you split a closed solid with the _Split command, it will leave the object open, i.e. you will have naked edges at the split line. If you wish to keep a solid object “solid” when splitting use BooleanSplit (with a surface/polysurface) or Wirecut (with a curve) instead.

–Mitch


(Litwinaa) #12

Thanks. Mitch. Maybe this is another way that could consistently work: I used Trim and afterwords ran cap planar holes. This eliminate the Naked edges that once again occurred.