Rhino 8 WIP takes mouse and keyboard focus when loading/processing

I’ve experienced Rhino 8 WIP releases to “swallow” all mouse and keyboard focus when they are stuck loading files or processing scripts. Global shortcuts such as those set up by programs like barrier stop working until Rhino finishes it’s processing.

I myself use Synergy and I have not noticed mouse or keyboard hogging by Rhino 8 WIP.

Can you elaborate how you identify this? In particular what is your server-client setup for barrier and how is the event blocking manifesting itself?

On barrier, windows server to a linux client, tunneled over ssh. In extreme case of the latest Rhino 8 build it wasn’t just Synergy, but the entire windows was blocked waiting for Rhino to finish - only could be unlocked with ctrl+alt+del. In prwvious rhino 8 releases it always manifested itself when opening a larger file, with lots of linked blocks, that took about 10 second to release.

I really really wish I could provide more information, but don’t know how to trace this weirdness. If you had any special tool that could help with diagnosing that, please let me know.

Sorry, I don’t have a good way or ideas to start investigating this. I’ll try some of my larger test files with blocks in to see if I can replicate.

I have my Windows machine as server and my Mac machine as client.

So loading heavy files on the Windows machine should see any input hang for some period of time, meaning I shouldn’t be able to use my Mac via my Windows in the mean time, correct?

So I installed WIP on the Windows machine (that I don’t use for development, but it is my Synergy server) and was able to replicate the problem by loading of a bigger file or doing things like meshing

Quick guess is possibly message pumping, but I don’t know at this point in time what is going on.

1 Like

Yes, that’s correct, no worries, there is probably something obvious that I’m missing that could solve this issue.

That’s great news, thank you. If you will be able to find out what causes it and it would be something that can be published, please let me know. This does sound interesting.

I’ve experienced a few other performance issues in latest Rhino 8 builds so possibly this might help solving them, as well?

After some more testing I have found that it helps to quickly switch to another app then Rhino won’t be blocking the mouse from entering the other machines.

Maybe an annoying workaround, but one that works well.

I have logged this as RH-71562 Rhino appears to be capturing all (mouse) events when active app

1 Like

Thanks, hmm I’ll see if it works when barrier is set to transfer the cursor when it reaches an edge of the monitor. I normally use a shortcut for that and when Rhino hang happened, even after pressing alt+tab to switch to another application I still couldn’t transfer the cursor to another machine (with a shortcut).

EDIT: yes, can confirm that the workaround you described worked here as well

Thanks for logging it, fingers crossed it will be addressed soon :slight_smile:

I’d uncross your fingers and get work done, I don’t think this is going to be solved anytime soon. The way Rhino event handling is set up makes it less than trivial to address.

1 Like

thanks for letting me know, I’ll bear that in mind. I’m experiencing other performance issues with the latest Rhino 8 WIP, so I think that the only way for me now to keep up with Rhino’s rolling release is to switch to a better workstation (which is a bit tricky, because the only candidate at the moment is a VM in a Linux laptop, which for some reason doesn’t seem work).

Rhino in VMs isn’t supported as earlier mentioned (and expressed on the system requirements page: Rhino - System Requirements ). So not really surprised you are seeing performance problems with Rhino 8 WIP.

You could always consider dual-booting…

Sorry, what I meant is passing through GPU to the VM isn’t even working for me yet, it’s something I was hoping to try to solve the issue above - all the above description referred to a regular single-booted “bare-metal” Windows machine.

Given that I’m already experiencing problems on a “correct” system configuration, how much worse can it really get…

Alright, I thought you meant you were already on a VM :slight_smile:

New problem, inserting blocks immediately crashes on this Rhino setup…
I don’t suppose you have an emergency hotline, by any chance?

Hi Daniel -

I launched Rhino 8 with a factory-default template, created a box at the origin, turned it into a block, and inserted that block. This didn’t crash Rhino here.
Does doing the same crash Rhino on your end?
Also, I’m not seeing any incoming crash reports from you:
image

-wim

1 Like

@wim after a while crashes stopped occurring - inserting blocks works fine now, but 20 minutes ago inserting new blocks was bringing Rhino down and without the “Send Crash Report” window popping up, so I couldn’t send them.

Thanks for the fast reply, but I’m not sure how to reproduce this problem now.

Hey @Daniel_Krajnik, have you tested this with Rhino 7? Does it behave any differently when it is loading files or meshing, or does it still lock up the mouse/keyboard when using Synergy?

I’ve been only using Rhino 8 WIP back then. Sorry, can’t reproduce it anymore.