Rhino 8 - Section Depth in 3D doesn't create clipping cube?

@rajaa - I’m bit confused about the custom Depth. I would think that it would create a “clipping cube” where you could only see what’s inside the cube - i.e. if you were to create a Detail view from the SavedSectionView, you wouldn’t see, say, the windows on a far wall beyond the origin of the clipping plane (or a nice option would be to set the opacity of the ClippingCube) Seems it’s sort of the inverse of this, where it clips the far side of the Depth entered, but beyond the depth, you can still see. Not sure how that’s useful?

EDIT: I see, when you CreateClippingDrawing, it does indeed only show the geo inside the Depth indicated. Can we make this work for 3D? I use the 3D SavedSectionViews in my Details, themselves, so seeing 3D geo beyond the Clipping Depth defeats the purpose for me. (Maybe I’m the only one?)

EDIT 2: Seems creating a mirrored ClippingPlane on the reverse side accomplishes my goal. Would this be a difficult built-in option for the next go-'round?

BTW, it would also be nice if you could control the WIDTH of the clipping, so instead of having to select the geo to include/exclude, you could just make the clipping cube whatever size works for the particular section you need. (Apparently Revit does this well, but obviously that’s a different horse of a different color)



In case anyone else has my same issue, I figured out the Depth works as expected, but in this case (maybe many) the ClippingPlane Properties “Objects Clipped” dropdown needed to be set to “All,” as opposed to Include Selected, which I had set it to.

Aaaand clicking the 'ol Solved button. (Farkas, party of one…? :grinning:)