Rhino 8 Print PDF

So, the Rhino8 version of saving or printing to PDF doesn’t really work too well. I had issues with V7 too but now pen mode doesn’t even print with V8. In V7 we solved my issue with the command testpdfexport which I’ve used for months now. Unfortunately I’m having issues with that command to and can’t export multiple pages at a time without issue. I have to export them individually and manually combine them which isn’t ideal. Any advice or solutions would be welcome.

Here’s a great example of the export option not working. First image is supposed to be Pen Mode… but it appears to be wireframe. And the second drawing is the exact drawing in shaded and for some reason the image is mirrored and not in the right location.

What is your current build number? Mcneel is introducing fixes in the “Release Candidate Channel”.

1 Like

My build number is Version 8 (8.2.23346.13002, 2023-12-12)

Do you know when those fixes will be released in an update?

Later this afternoon they usually release a new build, you can download it from here:
Rhino - Download - Rhino 8 for Windows (rhino3d.com)

HI Chris -

Note that Rhino 7 didn’t have vector export from the technical display modes. This is a feature that was added late in the development cycle of Rhino 8 and is still under construction. The current in-house 8.4 builds have several issues fixed and others are actively being worked on. For the time being, you might want to consider saving as a raster PDF file instead of vector.

That sounds like RH-76966 Print: Vector output prints layouts upside down - this was fixed and tested in Rhino 8.3. We are shipping a new public release candidate of 8.3 in a few hours from now. You’ll need to change your update frequency to release candidates in the Rhino Options, though.


Hi Wim. When are you expecting to launch this update? It seems it’s not out yet.

Hi Chris -

The update for macOS went out yesterday, the one for Windows is cooking now. Since you appear to be on macOS, …


1 Like

Ah! you are right. Thank you!

I’m still having the same issue as above. Both Raster and Vector printing have issues. Please advise.

Here’s what the raster claims to print:

This is what actually prints:

Here is what Vector claims to print:

Here is what Vector actually prints:

This is what I am expecting to print:


Printing as a Jpeg works the same as printing as a PDF

Please help. This is greatly effecting my work in a negative way.

Also, when printing multiple layouts it creates multiple files rather than putting them together in the same PDF. I can work with that but it’s annoying. The rest of this stuff I posted above doesn’t leave much room for working.

I’m exporting to rhino7 to get this to print but I get to re-hatch everything all over again.

1 Like

@pascal? @wim? @tay.othman?

Hi Chris - If you have not, please send us one of the files - the simpler the better - that shows the problem - tech@mcneel.com, to my attention.



Hi @pascal. Have you gotten a chance to look at the file?


Sorry for the delay.
We are looking at it now and will reply to your email to tech support.

Mary Ann Fugier

1 Like

Hi Chris,
We replied to your email that you sent tech@mcneel.com
These are all the issues that we logged or were already logged on the Pen mode display mode printing that you are using in the layout details.

To protect the files that you submitted, the YouTrack items are private and and not available for public viewing.
The YT numbers are below for your reference.

  • RH-79582/Vector-Printing-Issue-with-Details-in-Pen-Mode
  • RH-79692/Detail-in-Pen-Mode-Not-Printing-in-Raster
  • RH-79691/Detail-in-Pen-Mode-Not-Previewing
  • RH-79629/Fake2d-Not-Invoked-When-Printing-Layouts

You will be notified here when there is a fix ready to test.
As @wim shared above, the printing advanced display modes is a new Rhino 8 feature and there are few issues to workout.

Thanks for emailing the model.
Mary Ann Fugier

1 Like