Rhino 8 - Plug-in error on startup

I’m facing theses error messages when Rhino 8 is starting :

Not sure yet, but could it be my Windows system which might be outdated (Windows 10 Enterprise N 2016 LTSB, Version 1607, OS Build 14393.6452) ?

Best regards,

Hi Mathieu -

That sounds very plausible. I’m running Windows 10 Home, Version 22H2, OS build 19045.3693 and am not seeing those errors.

Create a shortcut of Rhino8 and call it for example Rhino 8 net

Right click and open properties window

space + /netfx

in the Target like this:

“C:\Program Files\Rhino 8\System\Rhino.exe” /netfx

You can then use all non supported plugins from Rhino7 To Rhino8

I just tried your solution, but no changes, I still get the error messages on startup.

Just to let you know, I upgraded my OS to Windows 10 Enterprise N 2021 LTSC, Version 21H2, OS Build 19044.3693 but, unfortunately, I am still facing the first (RhinoRoslyn) and last (RhinoCPython) error messages at startup (complete Rhino 8 reinstall + machine restart).