Rhino 8 - Named Views Active View reorderes last - Bug?

Each time I select a Named View the list rearranges placing it at the end.
I don’t think this is supposed to happen…

Hi Bogdan -

I’m not seeing that behavior here. Can you please provide the SystemInfo data?
-wim

hi @wim , thaks for checking this.

I attached the file. It might be something related to the Named Views created by Clipping Sections.
I saw other problems related to them, like if I pan or zoom them and resave the Named View doesn’t save the new position correctly.

240324 Named views from Clipping Sections Rearrange.3dm (14.8 MB)

Rhino 8 SR5 2024-3-12 (Rhino 8, 8.5.24072.13001, Git hash:master @ e3530849b75f00b2b977766a567ae29b055837e9)
License type: Commercial, build 2024-03-12
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 31GB)
.NET 7.0.0

Computer platform: LAPTOP  - Plugged in [100% battery remaining]

Hybrid graphics configuration.
  Primary display: AMD Radeon 780M Graphics (AMD) Memory: 1GB, Driver date: 8-9-2023 (M-D-Y).
    > Integrated accelerated graphics device with 4 adapter port(s)
        - Windows Main Display is laptop's integrated screen or built-in port
  Primary OpenGL: NVIDIA GeForce RTX 4070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
    > Integrated accelerated graphics device with 4 adapter port(s)
        - Video pass-through to primary display device

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 2-15-2024
  Driver Version: 31.0.15.5161
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 8188 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 8\Plug-ins\Commands.rhp	"Commands"	8.5.24072.13001
  C:\Program Files\Rhino 8\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	8.5.24072.13001
  C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	8.5.24072.13001
  C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp	"MeshCommands"	8.5.24072.13001
  C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	8.5.24072.13001
  C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp	"RhinoCodePlugin"	8.5.24072.13001
  C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	8.5.24072.13001
  C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp	"SectionTools"	


thanks for the report and file @Bogdan_Chipara
It looks indeed this is happening only with the named views generated by Clipping Sections.
RH-81284 Clipping Sections: Named view order

1 Like

@Bogdan_Chipara
Digging further into the options, this seems to be the expected behavior when you set the Named View options for the view to restore clipping planes. When the ClippingPlane is restored, the associated Named View is recreated and hence the order changes (it is added at the end), but it retains its name.

If you uncheck, you will not see that behavior. Does that help?