Rhino 8 Materials Error

I opened a file originally created in Rhino 8 in August. The material icons now show like this, but not for all materials. When I try to create a new material (Custom in the picture), it also shows the same icon anomaly. The materials with the odd icon are not displaying correctly in my scene. I am in Beta from 10/24.

Materials error

Not sure what the anomaly is you are talking about. Right-click the offending material and select to save as a file. Attach the resulting .rmtl file here so we can investigate.


The material name cannot be displayed on the Materials panel! emmmmm,

  Rhino 8 SR1 2023-10-31 (Rhino 8, 8.1.23304.10001, Git hash:master @ 00849e0909dc3cc92c425309d4f87320a4ef203f)
  License type: 试用版, 版本2023-10-31
  License details: Cloud Zoo
  Expires on: 2024-01-30
  
  Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 1.3e+02Gb)
  .NET 7.0.13
  
  Computer platform: DESKTOP 
  
  Standard graphics configuration.
    Primary display and OpenGL: NVIDIA RTX A5000 (NVidia) Memory: 24GB, Driver date: 10-11-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 545.84
      > Accelerated graphics device with 4 adapter port(s)
          - Windows Main Display attached to adapter port #0
          - Secondary monitor attached to adapter port #1
  
  Secondary graphics devices.
    Intel(R) UHD Graphics 770 (Intel) Memory: 1GB, Driver date: 6-15-2023 (M-D-Y).
      > Integrated graphics device with 4 adapter port(s)
          - There are no monitors attached to this device!
  
  OpenGL Settings
    Safe mode: Off
    Use accelerated hardware modes: On
    Redraw scene when viewports are exposed: On
    Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
    
    Anti-alias mode: 4x
    Mip Map Filtering: Linear
    Anisotropic Filtering Mode: High
    
    Vendor Name: NVIDIA Corporation
    Render version: 4.6
    Shading Language: 4.60 NVIDIA
    Driver Date: 10-11-2023
    Driver Version: 31.0.15.4584
    Maximum Texture size: 32768 x 32768
    Z-Buffer depth: 24 bits
    Maximum Viewport size: 32768 x 32768
    Total Video Memory: 24564 MB
  
  Rhino plugins that do not ship with Rhino
  
  Rhino plugins that ship with Rhino
    C:\Program Files\Rhino 8\Plug-ins\Commands.rhp	"Commands"	8.1.23304.10001
    C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp	"网页浏览器"	
    C:\Program Files\Rhino 8\Plug-ins\rdk.rhp	"Renderer Development Kit"	
    C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp	"RhinoScript"	
    C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp	"闲置处理"	
    C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp	"Rhino 渲染"	8.1.23304.10001
    C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	8.1.23304.10001
    C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
    C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp	"MeshCommands"	8.1.23304.10001
    C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	8.1.23304.10001
    C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp	"RhinoCodePlugin"	8.1.23304.10001
    C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	8.1.23304.10001
    C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
    C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp	"Displacement"	
    C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp	"SectionTools"

Below is a picture from August 9th using whatever version of the Rhino WIP that was available at the time.

I saved the 3dm as a Rhino 7 file. I opened the file yesterday and the image looks like this:

I start with the Lights panel, but the image looks the same with all lights disabled. I then go to the Materials panel, which looks like this when I begin:
Ground Plane 1

I change the Ground Plane color and then the icon looks like this:

The color does update in my image if I switch to Shade mode and then back to Raytraced. The icon corrects when I return it to the original Light Gray color. Here is the material:
Ground Plane.rmtl (11.6 KB)

I try a custom material.
Custom 1

As soon as I start to make changes, the icon changes.
Custom 2

This makes me think something is happening to the material. That’s why I posted yesterday.

On a side note, I can’t get my image to look like the one I saved in August and I’m still in the process of figuring out why. Hope this clarifies my issue, which may be moot with the release of Rhino 8.

Don’t get hung up to the fact that the rhino logo in the preview model gets a brighter - there is already a bug report for that, but it does not affect materials otherwise. The gray of the material is still correct in the ground plane material as far as I can tell.

I will have to get the 3dm file to see what is going on there.

Thank you for clarifying the icon issue. I was unaware it has previously been reported. This is the file I am working on.
Spheres.3dm (3.0 MB)

I have figured out how to correct the Rose and Yellow materials. I’m still working on the brightness, which seems to be influenced by the Light Dome layer.

The overexposed issue is due to the shadows-only groundplane. Further I’d change custom materials into PBRs. Apparently more has changed, and I don’t have yet a good view on what exactly. I did turn off the light dome layer, I haven’t looked into what it is yet.

Here with materials fixed up, light dome layer turned off and groundplane (shadows-only) turned off.

Spheres_jK.3dm (7.3 MB)

Thank you!

@dalvarez if you set the same environment you have as reflection environment also as 360° environment you can enable the light dome layer again.

I have to say I don’t understand the usage of that geometry with tinted and frosted glass, though. What is its purpose?

I teach Rhino for jewelry design and I’ve been experimenting with using three point lighting with a light dome. I’ve been getting very good results and students are producing better renders. The light dome diffuses the effect of the environment so it is more balanced and eliminates unsightly reflections. Here is an image with the light dome:

Here is the exact same set up with the light dome removed:

Thanks for figuring out how I can still use the light dome!

That is a nice idea, hadn’t thought of that!