Rhino 8 Grasshopper - Hide Wires Keyboard Shortcut Not Working

Hi there,

Just wanted to flag that the keyboard shortcuts for wire display in Rhino 8 Grasshopper doesn’t seem to be working. In Rhino 7 I was able to right click a component and hit “W” + “H” to hide wires, which was very handy.

Thanks for all the hard work!

7 Likes

Yes, none of those shortcuts work and I’m also waiting for them to be reimplemented…

4 Likes

@AndyPayne @Gijs @eirannejad @kike @brian @dale @DavidRutten
Dear Rhino 8 Developers,
This may seem like a minor issue but it’s the main reason why I’m holding off upgrading to RH8.
Grasshopper scripting is delightfully intuitive but it’s slow because it involves a lot of mouse dragging. At the moment the only keyboard assist available in Rhino7 is through right-clicking component inputs/outputs:
Right-click then F to flatten
Right-click then G to Graft
Right-click then W then H for hidden Wire input.
Right-click then S then S then Enter for “Select one geometry”

This was something, but it disappeared in Rhino 8

Please reinstate it or come up with something better :slight_smile:

3 Likes

This is on the list as
https://mcneel.myjetbrains.com/youtrack/issue/RH-73289

3 Likes

it doesn’t seem like a top priority for @DavidRutten
is there anyone else that can do this kind of UI investigation?

@curtis do you have a clue why this would work in Rhino 7 gh, but not in Rhino 8 gh?

Echo this topic!

I really need this short cut back. That’s a life saver feature in the previous GH.

Jiewei.

3 Likes

Looks like it is fixed with the latest update!!

Thanks very much McNeel!
image

… I spoke too soon. Seems to work when running Rhino.Inside Revit, which is great, but not when running Rhino Standalone. :frowning:

Does anyone know if there is a plugin that could do this?

It’s the kind of stuff that you miss the most when they are taken from you. The other day I was creating a panel with multiple values and wanted to toggle the panel to treat it as a list (non-multiline data), and tried the good old RMB+M and was devastated.

Without the shortcuts it’s like tying shoelaces with boxing gloves on.

1 Like

Sorry guys but I have to bump this.
This bug is driving me absolutely nuts and kills my GH productivity. Could you please please prioritize this?

Have you tried the latest 8.5 Service Release? :smiling_face_with_three_hearts:

I’m on Rhino 8 SR6 2024-3-6 and the shortcuts don’t work.

In most situations I’m using a panel without multiline mode, so I created a user object which also doesn’t contain any default text so I can enter my inputs straight away.

System Info

Rhino 8 SR6 2024-3-6 (Rhino 8, 8.6.24066.06001, Git hash:master @ 0af1b59a0c5932b51da39377fe3c154ed8b753bd)
License type: Kommerziell, build 2024-03-06
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 128GB)
.NET 7.0.17

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A5000 (NVidia) Memory: 22GB, Driver date: 2-7-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.52
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
NVIDIA Quadro K2200 (NVidia) Memory: 4GB, Driver date: 2-7-2024 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-7-2024
Driver Version: 31.0.15.5152
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 23028 MB

Rhino plugins that do not ship with Rhino 8 SR6
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24066.6001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24066.6001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24066.6001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24066.6001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.6.24066.6001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24066.6001
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.6.24066.6001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24066.6001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”

Running Rhino in .NET Framework mode (via SetDotNetRuntime command) seems to do the trick. Can you try whether that works for you as well?

1 Like

That seems to do the trick. What is the difference between Default, NETCore and NETFramework? Does this have an influence on other things?

I can’t describe it really well, but here’s an article:

So, in short, Rhino moved to .NET 7 which should have various benefits.

.NET Framework has been used in Rhino 7

Switching from default .NET 7 back to .NET Framework is a step backwards, no?

Exactly. Far from ideal. Hopefully this helps McNeel find the root cause for missing shortcuts and get them implemented in Rhino 8 without reverting back to an older framework.

1 Like

Wanted to just add to this as It is a frustration I am coming a crossed. I upvote this

I was going to add a post about how I cant hot key wire display and simple shortcuts as I am working. didn’t realize how much I use these until they were gone.

4 Likes