Rhino 8 GLB import does not bring in textures

Hello, have tried this today and while it imports the mesh geometry it does not import any of the textures. Is this working as intended or WIP or broken?
I tried these models:

Which both opened with textures in Blender when importing the GLBs.

assigned to Rhino category

Experiencing issues with GLB exports in Rhino 8 SR2. Not all textures and the environment are being packed. Also, transparency material issues. Exporting as GLB, default settings. Any solutions?

It’d be helpful if you provided an example file. Also updating to the latest service release candidate may help. I put in a fix for the transparency issue before the new year.

The notification for a new update version wasn’t showing up. I had to manually check for a new release. Downloading now. Will report back if my issue persists. Thanks!

I messaged you an example file that includes Rhino materials (Metal and Gem). The Gem material isn’t getting applied or isn’t appearing in a viewer. Any idea where I butchered things?