Rhino 8 Crashing Frequently

Rhino 8 keeps crashing while performing routine operations. Lately, it seems to crash while turning layers on and off. I have updated my video card and Windows is up to date. I get crash reports which I am sending to McNeel. What follows is my system info.

Rhino 8 SR8 2024-5-17 (Rhino 8, 8.8.24138.16021, Git hash:master @ 70a9d2157099e610ee64adcb72458b4742ef050f)
License type: Not For Resale Lab, build 2024-05-17
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 16GB)
.NET Framework 4.8.9241.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro RTX 4000 (NVidia) Memory: 8GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port 0
- Windows Main Display attached to adapter port 1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

1 Like

Hello- is this file specific or with any file? e.g. is it possible layers turning on may show something that Rhino is having a hard time shading, say?


Hey Pascal. It has happened with two different files today. This has happened in the past but when I updated Rhino, that corrected the issue. But not today. I’m just drawing lines for a boat. There are some surfaces in the file but no shading.

Hello- if you can send us the file (tech@mcneel.com) and some idea of the steps to reproduce the crash if that is possible - you may have outlined this in the crash reports - thanks for sending those in - if so, we can work with that I think.


Will do. Thanks.

@majors101 one of my colleagues noticed the .NET framework - we’d expect .NET 7.0

Did you make that change?


I did not.

@majors101 - it’s possible things may work better if in Options > View > OpenGL page you un-check ‘GPU tessellation’ for now. It’s better if that is on, in general, but the crashes seem to be associated, possibly, with clipping planes and we;'ve seen that sometimes helped by unchecking that setting.


1 Like

Hi @majors101,

Are you launching Rhino.exe with the /netfx command line parameter, or does Rhino’s SetDotNetRuntime report NETFramework?

From your crash reports, it looks like your dragging layers in the Layers panel. Is this correct?

– Dale

I will give that a try.

I was using Orca’s WIP for a bit and then uninstalled it. If I remember correctly, I had to add something to the .exe name. It might have been the /netfx parameter but I do not remember.

Please be sure tp set GPU Tessellation setting back to checked if it - as is likely, I’m told - does not help.


HI @majors101,

Check the properties of your Rhino shortcut:

If you see “/netfx” after “Rhino.exe”, please remove it.


– Dale


I know that I added /netfx when I started using Orca but when I checked the shortcut this morning, it wasn’t there. My shortcut looked like your image.

I missed the second part of your question. When I run that command, I see “Currently running .NET in NETFramework.”

@majors101 - Please run Rhino’s SetDotNetRuntime and set Runtime to Default and then close and restart Rhino.


– Dale

Done. I will be using Rhino for most of the day tomorrow. I will respond to this thread if the problem persists. Thanks for your help.

1 Like

Well, I thought the problem was corrected but Rhino crashed on me again. It seems that it crashes when I am turning layers on or off.

@majors101 - did you submit a crash report?

– Dale