Rhino 8 blocks not casting shadows

Hi - For some reason when I block geometry in Rhino 8 (rendered display) shadows are not cast. When I explode the block shadows are cast (and prior to blocking). Here are images of the underlying geometry (casting shadows) and what I get when I turn the geometry into a block. The blocks are set to cast and receive shadows, so this must be a different issue. Any ideas?

Matt Winkelstein

Hi Matt, I think this has been fixed - what sr are you using? Can you copy/paste the output from the SystemInfo command in Rhino?


Sure - here it is:

Rhino 8 SR6 2024-3-12 (Rhino 8, 8.6.24072.13331, Git hash:master @ b1dd703644066ef091e7a183836a7c7350bacb46)
License type: Commercial, build 2024-03-12
License details: Stand-Alone

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.17

Computer platform: LAPTOP - Plugged in [98% battery remaining]

Standard graphics configuration.
Primary display: DisplayLink USB Device (DisplayLink) Memory: 0MB, Driver date: 4-16-2020 (M-D-Y).
> External USB display device with 2 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce RTX 3070 Ti Laptop GPU (NVidia) Memory: 8GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

Secondary graphics devices.
DisplayLink USB Device (DisplayLink) Memory: 0MB, Driver date: 4-16-2020 (M-D-Y).
> External USB display device with 0 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed
Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 10-6-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-15-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\mwinkelstein\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\Corgi\0.5.15\Corgi.rhp “Corgi”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24072.13331
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24072.13331
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24072.13331
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24072.13331
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24072.13331
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24072.13331
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

dude its that 8 gigabytes on your gpu try using a i9 quad core with a Samsung p1000.

Hi Matt -
I’m not seeing that in a quick test here:

A few things to try:

  • What happens when you disconnect external screens and use the laptop’s screen (and restart Rhino)?
  • What happens when you disable the two 3rd party plug-ins and restart Rhino?
  • Your Rendered mode is a modification of the default mode. What happens when you use the default settings?


Would you be able to clarify that, what should I have for this setup? It’s a company machine that came that way. Would love to be able to describe the preferred specs.


I was getting that issue with all display modes and on laptop screen alone. I did notice that depending on the level of zoom, shadows changed, disappeared and reappeared depending on the camera based clipping shadow radius setting. And a radius setting that got the shadows to work with one model would need to be changed for a different model. In all cases the default settings required adjustment of clipping radius to activate and refine shadows. Not clear to me why each different model and level of zoom would require a shadow setting adjustment. Ideally getting good shadows wouldn’t be this challenging… Is it possible this is due to inadequate graphics card video memory (8 GB)? These are not highly complex or heavy models.


Hi Matt -

A lot depends on the extents of the scene and extents of some of the objects in that scene. If you can post or upload (Rhino - Upload to Support) a 3dm model, the developer can take a look at what’s going on here.