Rhino 8 BETA - OSnap is not working properly

i got the new Rhino 8 BETA. The OnSnap does not seem to be working properly. it snaps sometimes, but to most of the objects it does not. Am I missing some setting for Rhino 8 which is new, or is it a software bug that needs to be fixed?

Please provide details such as WHICH version of the Beta, you are using, since it has changed every week for the past month or so. We are currently at (8.0.23292.13303, 2023-10-19) - I see issues too.

Run the Rhino command SystemInfo and post the results here.

Which Osnaps do you have turned on?


I changed the topic title.

1 Like

Hello. I have the same problem, till yesterday all worked fine to me. Now it is impossible to enable Osnap on surface, curves ect.

1 Like

I am using the first one in the picture you have shown (the one with disable). 8.0.23292.13303 2023-10-19 . so the same one you are currently using.

I think the Osnap is not working properly for rhino 7 geometry? When i make new geometry in rhino 8 and tested it out it did not have any problems.

Rhino 8 SR0 2023-10-19 (Rhino 8 BETA, 8.0.23292.13303, Git hash:master @ bdbf32cf54f4fdd6a528fcb0214c29cce2cdddbe)
License type: Educational, build 2023-10-19
License details: Cloud Zoo
Expires on: 2023-12-03

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 32Gb)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 2-22-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Ti Laptop GPU (NVidia) Memory: 8GB, Driver date: 8-4-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 536.99
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-4-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter”
C:\Users\Varun SA\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\Walkie\\Walkie.rhp “Walkie”
C:\Users\Varun SA\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\D5Conv (e0d5e210-02f6-4ee9-a2b0-1675e225d958)\\Rhino 7\D5Conv.rhp “D5Converter for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.23292.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23292.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23292.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\MeshCommands.rhp “MeshCommands” 8.0.23292.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23292.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23292.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23292.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8 WIP\Plug-ins\SectionTools.rhp “SectionTools”

Can you post an example file with Rhino 7 geometry imported into 8 that is not “snappable”?

I’m running into the same problem. I want to run Shrinkwrap on mesh geometry I was given. I need to mirror the geometry to create the entire airplane before I run Shrinkwrap.

I can’t get Osnap to work at all, not even on geometry I created in Rhion 8.

2 posts were split to a new topic: Osnaps not working

I recently ran into this with a customer that was running an unsupported, under spec. Intel GPU a couple weeks back. V7 sort of worked (slow), but in V8 the Osnaps didn’t work at all.

Several other people had their Selection Filter set so nothing could be selected.
Another person had their Osnaps disabled.

Your SystemInfo looks okay but if it were me, I’d update the Nvidia drivers: