Rhino 8.7 color bug

In the attached drawing there are two planar surfaces made with PlanarSrf command. They are in the same layer, but left surface is much darker than right surface.

rhino color bug.3dm (88.7 KB)

Opening it in local 8.9 they look the same. Took a screenshot and compared the colors in GIMP, exactly the same:

I still see difference shown in the following picture. There is big difference on my laptop screen, smaller difference on my 4k monitor. All my hardware and software is perfect.

I see this if I have “Color backfaces” turned off in my shaded display mode. The “C” is then considerably darker - RGB 85,85,85, while the other surface is RGB 103,103,103.

The C-surface is flipped relative to the other one (you are looking at its backface). If you flip it so it’s front-facing, the colors become the same (103). Normally I have color backfaces on and set to red, so the C popped out as red immediately on opening the file…

I don’t know if this is considered a bug or not…

You are right! These surfaces were oriented in opposite directions. Flipping one of them solved the problem. (I was too stupid to figure it out.) I had backfaces set in Options>View>Display Modes>Shaded to “Use front face setting,” so in theory both sides should not look different. Another Rhino flaw is that these surfaces look much darker in Perspective viewport than in Top viewport.

Naa, just that I have backfaces set to red, so the difference immediately jumped out at me.

I think this is a bug anyway, I will create a YouTrack item for it.


More trouble… I set backfaces in Options to custom pattern/texture and the problem appeared again, despite all the surfaces oriented in the same direction. Left surface is lighter in Top and Perspective viewport. This problem seems to be random…

I think this is the same issue as https://mcneel.myjetbrains.com/youtrack/issue/RH-69567/Display-Shaded-views-depend-on-normal-direction - which pulls together several forum threads.

Turning this setting on will cure it:

but has the side effect of darkening the shade.

I don’t know if @nathanletwory sees both items the same because he has that setting on or because this finally gets fixed in 8.9. Let’s hope it’s the latter…


Advanced GPU lighting makes my surfaces darker, but the colors are still different.

That’s a shame. Here’s what I see:

Assuming the difference you see is measured and not the result of an optical perception phenomenon such as simultaneous contrast, I wonder if there is an interaction with other settings. Do you have any non-standard settings relating to colour?

Checking Advanced GPU Lighting makes the colors the same and darker here. (66,66,66)

I cannot recreate this bug now. When I return backfaces to default setting (same color as front faces) both surfaces have the same color. The only flaw I see now is that the color is much darker in Perspective viewport than in Top viewport.

No, My Rhino installation was not configured - this is why backfaces were nominally the same as front faces. Probably the cause of the problem was that the color is very dark (R=B=G=1).