Rhino 7 to 5 Annotation/Dimension error

I regularly work in Rhino 7 but sometimes colleagues or clients I am working with are using Rhino 5 or 6. This inevitably means that at some point a file gets saved in 5, 6 or 7 and as a result when I open the file in R7 the dimensions, annotations and text fall over, despite the fact the file was first saved as a R7 file.
E.g. Text and leader text repeats itself many times!


Subsequently I will then have to update each individual bit of text for a file or drawing which is a waste of time and sometimes gets missed and issued to a client incorrectly.

This is also the case for dimensions. I have no understanding of why this occurs but it may be down to the viewport scale used. See example below. The dimensions showing 35 and 25mm are incorrect and are what are shown when the file is opened for the first time. Whereas 150 and 210mm are the correct dimensions which were originally shown within the file and I have just had to add myself.

Can anyone shine some light on what is going on here? Does anyone else have this issue? Very frustrating given this also affects Blocks and drawing templates.

Thanks,

G

Hi Gavin -

The annotation system was thoroughly updated between Rhino 5 and 6 and some loss of information will occur. That said, I can’t reproduce the issues that you are describing here. Could you post a simple 3dm file with instructions on how to reproduce this?
-wim

Hi Wim,

See files attached.
The first file attached is the original created in R5.
The second file attached is the first R5 file saved as a R7 file. This is where the dimensions fail.

The text and leader annoyingly have not produced the usual results of repeating the inputted text but as you will see it has caused the annotations to scale by 1:8 which is the same as the viewport scale.

ExampleA R7.3dm (735.7 KB)
ExampleA.3dm (722.8 KB)

G

Hi Gavin -

Thanks for these.

I opened “ExampleA.3dm” in Rhino 5 and saw a rectangle in a detail that was dimensioned on the layout and the dimensions read 1000 x 750.

I then opened “ExampleA R7.3dm” in Rhino 5 and saw the same thing there, also reading 1000 x 750.

Finally, I opened “ExampleA.3dm” in Rhino 7 and saved as a Rhino 7 file. I closed Rhino and reopened that last file. The dimensions still read 1000 and 750.

Should the above procedure have shown anything different? That is, does it on your system?
I notice you are running 7.8 while I am on 7.12. Could you update to the current service release candidate 7.11? Also, please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Hi Wim,

This is what I am seeing on my PC. As you can see the dimensions are scaled by viewport scale - 1:8.

See SystemInfo below:
Rhino 7 SR8 2021-7-15 (Rhino 7, 7.8.21196.05001, Git hash:master @ 45c1fd6dc85c7c1cce8c0bbe6f3e16481ae9abfa)
License type: Commercial, build 2021-07-15
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 6-24-2021 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA T500 (NVidia) Memory: 4GB, Driver date: 7-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 471.41
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-12-2021
Driver Version: 30.0.14.7141
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I will also try to update to 7.11

Thanks

Yes, please.
-wim

Hi Wim,

I have updated to the latest available version which is 7.10 but this has not solved my issue.
If 7.11 is available can you send me a download link as it is not available within the software updates tool and I cannot find it online.

Thanks

Hi Gavin -

7.11 is currently the latest stable release and the regular Service Release setting in Rhino Options > Updates & Statistics > Update frequency should have notified you of an update by now. You can also set that to Service Release Candidate, which will download 7.12.
-wim

Hi Wim,

I have downloaded 7.12 but it has not solved these annotation issues.

Here is another example below. This drawing border template was produced in Rhino 5 originally, then saved as Rhino 7. For example, when back saved to Rhino 5 for other parties to edit a drawing, it changes all the fonts to something random but also alters the text formatting. See second screenshot.

You will see some of the text has now been stretched out and repeated and ALL fonts have changed to Century even though some of the template is saved as a block or just grouped.

Here is the file TYD 2D A4 Landscape Master template_REV A.3dm (2.4 MB)

If you can look further into this example and the dimensioning issues stated previously, that would be much appreciated as this causes significant time wasting as well as difficulties with manufacturing drawings being dimensioned incorrectly.

Thanks