Rhino 7 and annotation dimensions

Hi,
I am having an issue with importing DWG files into rhino 7 (WIP - 2020-11-09).
This is similar to the old issue in Annotation scale between Rhino and AutoCAD

The font for dimension numbers overwhelms the drawing. Here is an image sample:

I can take the layer, select the dimensions -> properties and change the height and model space scale (from 20/304.8 to 10/1.0) and they are find on top view. Layout view still has them in monstrous size.

What is the easiest way to change the size of layout dimensions ?

Thanks for any help.

Hi Don,
This is the same in Rhino 6 and 7.
You should try turning off “layout space scale”, first.

Layout scale when off, Rhino displays the text height calculated in Model space and adjusted by the scale of the detail.
So that text that is 6" high will be adjusted by the detail scale of 1/48, and display at 1/8. But not display 6" high, like if does when Layout scale is on.

The more time consuming fix, is to correct your annotation styles so the values like arrow size and text height, and others are the exact height you want on Layout. For example, text height should be 1/8" if you want it to print 1/8".

See if that help. If it does not, PM me with a link to download a file.

Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA

Hi Mary,
That does help. Even though every file that was having problems before, has that setting unchecked.
(i am coming from rhino5 straight to rhino 7 as the DWG files would not work in rhino 5)

I still need to resize every DWG that comes in from the architect. Is there any near-term release on the long term fix of understanding autocad annotation info and adjusting properties in rhino so that it works?

I will know over this week if I find other issues with this.

Hi Don,
Thanks for sending the file. The fix was a little more complicated.

  1. First I turned off the Model scale, the Layout scale was already off.
  2. I changed all the style to a Model scale of 1.
  3. I selected All and set the Display color to “By layer” (white is white in Rhino, white is black in AutoCAD on a white background and black on a white background.) I changed the yellow layer to block - it was impossible to see and interferes with the highlight color.
  4. Then I changed the Options -> Unit -> Layout to MM, and pick “No” to not scale the geometry.
  5. I changed the Layout Properties orientation to Landscape
  6. I locked the detail.
    Then it looked pretty good.

I think this can be done in under 2 minutes!
Sincerely,
Mary Ann Fugier

Mary,

Thanks. your method works.
the key part for my DWG files was to change each style to model space scale.
-Donald

1 Like