Rhino 7 low res - blurry material preview thumbnails

Hi there,
I’m running a 2019 Macbook Pro with the Radeon Pro 5600M 8 GB GPU + 64 GB RAM + 2 TB SSD, pretty much maxed out.

Running into an issue where the previews / thumbnails in the Material Panel are showing up in low resolution and blurry. Changed the Cycles settings and pretty much maxed out the resolution sharpness, CPU utilization at 50% and responsiveness at 75%. I tried different scenarios but nothing worked. See pic below.

The thumbnails of the materials look fine when previewing in Finder.

Can anyone help with this?
Many thanks in advance.

Wanted to add sometimes when I close the program and reopen, the previews will be normal resolution and then turn blurry one by one.


Hello- does a rendering or ray traced viewport look correct?


Hi Pascal,
Thanks for the quick response. Rendering and Ray Traced viewport looks fine. Just the materials panel is blurry.

Hello - can you please run SystemInfo in Rhino and copy/paste the results here?


Here you go. Thanks Pascal.

Rhino 7 SR7 2021-6-9 (Rhino 7, 7.7.21160.05002, Git hash:master @ d2161989109d5dacba531310b5d345ce6f4da9f6)
License type: Commercial, build 2021-06-09
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 10.15.7 (Build 19H1217) (Physical RAM: 64Gb)
Mac Model Identifier: MacBookPro16,4
Language: en-US (MacOS default)

AMD Radeon Pro 5600M OpenGL Engine (OpenGL ver:4.1 ATI-3.10.21)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8176 MB
Graphics: AMD Radeon Pro 5600M
Displays: Color LCD (264dpi 2x), DELL U2720QM (218dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
AMD Radeon Pro 5600M (8 GB)
Color LCD (1792 x 1120 @ 59 Hz)
DELL U2720QM (2560 x 1440 @ 60 Hz)

USB devices
Apple: composite_device
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
Broadcom: Magic Mouse 2

Third party kernel extensions

Third party plugins
/Users/voyager/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.0/libtbb.dylib
/Users/voyager/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.0/libtbbmalloc.dylib
/Users/voyager/Library/Application Support/McNeel/Rhinoceros/packages/7.0/ProRender/
/Users/voyager/Library/Application Support/McNeel/Rhinoceros/packages/7.0/ProRender/
/Users/voyager/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.0/libOpenImageDenoise.1.2.3.dylib

Rhino plugins that do not ship with Rhino
/Users/voyager/Library/Application Support/McNeel/Rhinoceros/packages/7.0/ProRender/ “ProRender”
/Users/voyager/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.0/IntelDenoiser.Mac.rhp “IntelDenoiser.Mac”

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoBonusTools.rhp “Rhino Bonus Tools” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/SolidTools.rhp “SolidTools” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoLabsTools.rhp “Rhino Labs Tools” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.7.21160.5002

Hi Pascal, hope you had a nice weekend. Just wondering if you were able to extract anything from the report. Lmk, thanks!

Hello- nothing very definitive to my eye, though I do wonder about ProRender- Just as a test, close all but one file, then in Preferences > Plug-ins disable ProRender and then quit and restart Rhino - any difference?


I had similar problem described here: Rhino 6.22 - missing library icons
TestRestoreLibraryFileAssociations command solved this problem. (I use Windows.)

Hi Andrew, thanks for the heads up. Wonder if there’s a Mac command for this. I tried a few word strings but nothing looks close to RestoreLibraryFileAssociations on a Mac.

Hi Pascal or anyone from McNeel, do you know the Mac version of this command?

Oh, I tried disabling ProRender CPU and GPU but that didn’t work.


It’s 2am in NYC and about to cry. Besides the material panel crapping out, everything else is failing. My model decided to inexplicably change all the materials on it’s own. All texture mapping lost. Browse all Versions crashes every time I launch. Crashes when I try to render. Takes 20 seconds to load Named Views with only 5 views. Have no other programs open except a newly opened Chrome browser to reply to this message. Everything was running fine, I produced a rendering, closed out the render panel and everything was fine. Went to watch TV and when I came back an hour later, the dominos started to fall beginning with incorrect material assignments. I went to Revert to previous version and it crashed . When I reopened, all my Panels and Tool palettes were gone. I clicked the sidebar to reveal the palettes and everything had reset to default. Copy / pasted into a new file and still crashes when I change the viewport to Render view. Crashes when I try to render as well.

If single Rhino model/file is causing all these problems, I would dissect this model until the problem is found. (I had less severe problems caused by corrupted model.) First, I would use Audit3dmFile command to find out whether the model is corrupted. If it is corrupted, I would use Rescue3dmFile to recover as much data as possible. If the Audit3dmFile finds nothing wrong, my best guess is that something is wrong with at least one material - I would delete all materials before purging (Purge command) material definitions and everything else that is not essential. If the purging does not help, I would give up.

If this problem is not related to single model/file, I would launch macOS in Safmode, and then start Rhino.

Thanks Andrew. I copy and pasted the model into a new file and changed all materials to a simple white and remapped the textures. Couldn’t pinpoint the offending map but it seems more stable now. Really appreciate your help! Now on to figuring this pesky blurry material thumbnail preview. Even tried reinstalling Rhino 7 with no luck. Small victories…