Rhino 7 icon's is overlapped in rhino 6

I’m using rhino 6 sr 29
and rhino 7.1.20314.23101

1 Like

The current version of Rhino 6 is 6.31.20315.17001. You might want to see if that version has the same problem. There may be an even newer one released tonight.

The newer service releases notes didn’t mention any thing about this Bug so I’m gonna wait the next SR to see

@wim, @brian, are you aware of this?

Yep, I’ve tried to fix it several different ways, and the results are disappointing. I can fix the overlapping only to make it so that pinned taskbar icons disappear with each service release install. I’m not sure which is more important - can you please vote?

I’d vote against disappearing pinned icons. I’ve got 4 of them (for v6 and v7 in EN and PL)…
image

Brain I’m sorry for not updating u with the changes but the problem has been solved after updating R v7

You just have to delete the old taskbar icon and repin a new one every time a new service release is installed.
That’s the way it works with many other programs. Not a big deal imho.
So @brian, I vote for the fix of overlapping/confused taskbar icons.

@brian
I just checked:
newest releases for Rhino 6 and 7, Rhino 6 instances appear under the Rhino 7 task icon (as do Rhino 7 instances).
So at least for me the problem continues.

Hello!!
for me i launch Rhino 7, and it do that:
image
no rhino6 open, just one 7 open…

Same for me, Launched 7 but icon for 6 is active. Functionally seems to work still. shrug.

1 Like

I was having this issue.

I figured out that apps are stacked in the taskbar by their AppUserModelID. Looks like very few programs specifically set a value for the process, window, and shortcut. Windows automagically gens an ID for programs that don’t specify a value.


I was able to find and get rid of the V6 one. Run “shell:appsfolder” to get a list of apps on your PC. Alt+V to show Details and then Choose Details. Add the AppUserModelId column.

image

image

image

Right click the Rhino 6 instance and Uninstall.

image

F5 to refresh the view and it should be gone.


Now I can pin Rhino and have the V7 one. Right-click now works for recent files as well.

image

Good work!
I need to investigate if that solves my problems.

But ultimately, shouldn’t the vatious Rhino versions have different ID’s assigned by McNeel to avoid the problem at its root?
NB.: Not an expert here, there might be good reasons for McNeel not to.
So read this just an honest question

i don’t understand, but for me i cannot show this column it’s grey!

are you uninstall Rhino 6?

because i need V6… when i open A R7, it open it under V6 icon, and i can’t acces to the V7 recent file…

I’m not sure in your case then. The shell:appsfolder is basically your Start menu. Maybe you don’t have perms to edit the Start menu? Plus, if you try to uninstall something that is actually installed it should take you to Programs and Features.

Maybe @brian can chime in if they’ve tried setting the same AppUserModelId for the process, window, and Rhino.exe file? From what I can tell, setting them explicitly would fix this. Otherwise, MSFT generates an AUIMD and uses heuristics to try and stack like with like in the taskbar.

not sure if this is the same issue you guys are having, but when i select not to combine taskbar icon my rhino 7 icon works properly when the program is on. when i close the program the smaller icon for some reason always wants to read rhino 6, since ive uninstalled rhino 6 it is now showing a blank white paper when rhino 7 is pinned. when i choose to combine icons together and open rhino 7 its still reading it as rhino 6.

to summarize i believe the smaller icon/badge is messed up and keeps wanting to read the program as rhino 6 instead of 7.

rhino 7 - combined icons in taskbar rhino 7 off - icons not combined - pinned rhino 7 on - icons not combined - pinned

It’s the same issue. You should be able to follow the steps I listed to fix it.

thanks Eric, will follow the steps you’ve listed above and let you know what happens.

Helo, for me there is a problem, i stoped to combine icons so Rhino open with a rhino 7 icon and rhino 6 with rhino 6 icon, but with a right click on rhino7 icon, we can see it want to open a rhino 6:

@wim, I saw in this doc:

that we can rename the executable of rhino.exe to rhino6.exe and rhino7.exe, is it a solution?

I just installed 7 and am having the same problem. The only way it visually seems to work in the taskbar is if you choose to never combine icons in the taskbar setting. That way you will see both 6 and 7. But even then, if I right click the taskbar 7 and choose a file, it opens it as 6. I saw a post that mentioned that both executable files are called Rhino.exe and that may be the problem, but it isn’t. I have 4 different versions of Autocad on my computer and everyone of them launches from a file called ACAD.exe. And every one of them comes up with it’s own taskbar icon. Seems pretty ridiculous that this is still not resolved.