Rhino 7 delete (Zoo) license file on upgrade

Hello,

we are using Rhino 7 with Zoo license (30-user license, Educational). If we install update (new SR), the installer deletes lic file from c:\ProgramData\McNeel\Rhinoceros\6.0\License Manager\Licenses, so we need to specify the license on the first run of newly installed SR of Rhino 7.
Even if we specify the Zoo server in advanced settings of the installer.
Interestingly enough, it deletes only lic file of Rhino 7 and lic file of Rhino 6 keeps intact.
And Rhino 6 is not doing it.

We use classic Zoo server, not Cloud Zoo.

Stanislav OlivĂ­k

How are you installing Rhino 7?
Are you running the Rhino 7.3 installer?
Are you using the scripted deployment tools?:
https://wiki.mcneel.com/rhino/installingrhino/7

I was using Rhino 7.4 installer (Release Candidate) in normal (interactive) mode. It behaves like that from the first SR, but was not doing it when it was WIP or beta version. I have tried various SR on computers with both Rhino 6 and Rhino 7 installed, and with Rhino 7 only.
There is a similar topic from user, who uses script and have the same problem.
I contributed to that topic, screenshot from my installer is there.

Today I tried the latest RC version of SR4 (installer rhino_cs-cz_7.4.21054.09561.exe). Even without going to advanced settings, it deleted the license file when finishing installation.
rhino_install

By the way, maybe the lic file should be placed in c:\ProgramData\McNeel\Rhinoceros\7.0\License Manager\Licenses if it is Rhino 7.