Rhino 7 - BLACK screen in Rendered View

Is there a solution to this issue?

it’s typically a graphic card issue, you need new drivers (clean install) and you need to make sure all monitors are plugged into the video card, and not the motherboard monitor port.

post your systeminfo results from rhino for more specific help.

I tried almost everything at this point. here’s the system info.

Rhino 7 SR4 2021-2-16 (Rhino 7, 7.4.21047.11001, Git hash:master @ fcf2374e901bd5fefe6baacfa9d0554aff427bac)
License type: Evaluation, build 2021-02-16
License details: Stand-Alone
Expires on: 2021-05-18

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 1-8-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

if you disconnect your external monitor does it work?

Also your gtx card had a game ready driver and a studio driver… try the studio driver with a clean install (choose advanced, or custom when you install the driver and check the clean install option)

I really need to get this fix as soon as possible. I have so much work to get done, but no other helpful contacts.

call us- (206) 545-6877
we are closed for lunch until 1pm pst but are here till 5pm pst

sorted via phone call-

fwiw folks, if you are struggling with something that is preventing you from getting your work done- please call or email us directly at tech-

the fix here was to change the nvidia settings, reset the rendered view to defaults and reset the rendering panel to defaults.


Hey Chris,

So is your problem the same issue I was having above, where your rendered screen was black?

Try changing Anti-Alias from 8X to 2X.

That seemed for work for me. It was when I was trying to use anything above 2x that it was black.


Fixed over the phone. Kyle was a life saver! Just call them (206) 545-6877 if anyone else is having this issue.

Very Thankful!

Fixed over the phone. Kyle was a life saver! Just call them (206) 545-6877 if anyone else is having this issue.

if in the UK, what is the equivalent number to ring, as ringing USA, unless they are on whatsApp, is financially a killer, £10,…£20,…£30 ramps up in tens of minutes, and the MB shuts off as a ceiling of £10 is set.
Have they WhatsApp ?


call our barcelona office, they handle all the europe support.

That fixed the issue for me as well.

Hi everybody,
I am having a similar issue with the black viewport, however, whenever it happens it is for all of the viewpoerts at once, even if I open another session. I adjusted the computer power use and gave Rhino performance preference on the graphic card. I changed “antialising” for 2X too. That solved the problem, however once in a while I had the same problem again. I could go around it by Restarting Rhino or Restarting the computer when Rhino only wasn’t enough. Now this is happening quite often (3 times each morning or afternoon). That is really time consuming nowadays, having to connect to VPN, get a ZooLicense and so on. I would like to fix it once and for all.

Anybody has an Idea of what else could be done that I haven’t done yet?

Thanks, Felipe

@felipepdoac almost always this is a graphics driver issue. Update all your drivers (intel and standalone) if so equipped.

use the custom install option, and then check the “clean install” option- restart and try rhino again.

also see this article- Soooo, you bought a laptop with hybrid graphics and rhino doesn't run right. READ THIS - #4 by theoutside

also make sure you run help>check for updates in rhino to make sure you have the latest service release.

1 Like

hi Steve, you can call anywhere in the US for free (e.g. from outside the US) using https://hangouts.google.com, at least for a while longer (it now shows a notice they’re going to discontinue the service). I use it all the time to call family.

Skype is 3¢ a minute to the US…

Hi everyone.
I have a solution:
first step: Tools > Options > View > OpenGl: turn off/ set none: GPU Tessellation
second: Tools > Options > Advanced > then turn off: Rhino.Options.OpenGL.UseHardwareDriver

Thanks for the solution, HungaroCAD Budapest and Rhino Barcelona.
Have a nice day!


Huge thank you for that comment! It worked perfectly for a blackout of all four viewports :smiley:

Please note that this is ONLY a solution if you are running very old or underpowered hardware and should only be applied when all other options have been tried. You are basically crippling Rhino to run on the bare minimum of instructions in terms of graphics, and you use none of the (potential) power in your graphics card.

1 Like

WAIT!! before you do this… make sure to check all your graphic driver dates.

if all you have is an intel hd, grab this tool and update your intel driver.(IMPORTANT!! don’t use the update driver function of the device manager it’s a complete POS and does NOT work)

update your intel drivers, restart your machine and try rhino again.

if it fails, don’t cripple the gpu as stated above, use the open GL slider instead. drag it one click to the left at a time and try rhino. if it does not work, drag one more click to the left until it works correctly.

Posting the results from running the systeminfo command in rhino will help us a lot in understanding which part of your machine is having the problem.