Rhino 7 and 8 "Not Responding"

In the last week or so, I notice slowness in response (click a window or command, then a delay) or a formal “Not Responding” may appear. Sometimes after a few commands, but especially when I change a viewport display from anything to rendering or raytracing or back. (I first noticed in 8, so I am working in 7 right now)

Files are from 20MB up to about 100-150MB. (I will upload one for reference later)
I normally keep all my data in folders on a local drive (D:/) that is also my OneDrive home

So far I’ve tried the following, but havent noticed any improvement:
1- I tried working from a desktop folder (outside of my OneDrive)
2- Updated video driver, clean installation. Using “high performance” System>Display>Graphics setting for Rhino7 and Rhino8
3- disabled 3rd party plugin (Substance Importer)

Is there anything I can do to improve application performance?
thanks, John


My Rhino 7 System Information: (8 below)
Rhino 7 SR37 2024-4-16 (Rhino 7, 7.37.24107.15001, Git hash:master @ d2e42f70b9d3aa58f6053e2998a0db2abcd7555b)
License type: Commercial, build 2024-04-16
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 5-13-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.85
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-13-2024
Driver Version: 32.0.15.5585
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”


Rhino 8 info

Rhino 8 SR7 2024-5-17 (Rhino 8, 8.7.24138.15431, Git hash:master @ 03702f889bdef32626af4bca510b5e8a85666d38)
License type: Commercial, build 2024-05-17
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 5-13-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.85
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-13-2024
Driver Version: 32.0.15.5585
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hi John - nothing jumps out at me in your SystemInfo results - do I understand correctly that before a week ago Rhino behaved normally with the same files? Was there a Windows update or any hardware change that you are aware of in that timeframe? Does it occur with some files and not with others?

@John_Colby - I see the lag here with the file you sent us (thanks) . I’ll inverstigate but I suspect it will just need to go on the bug pile for a developer.

RH-82219 Slow display mode switch

-Pascal

Hi Pascal,
yes you understand correctly Rhino was working correctly about a week ago. The following updates were applied recently:
05-17-2024
" Dell Update Windows Universal Application - A00"
“2024-05 Cumulative Update for .NET Framework 3.5 and 4.8.1 for Windows 11, version 23H2 for x64 (KB5037591)”
05-16-2024
“2024-05 Cumulative Update for Windows 11 Version 23H2 for x64-based Systems (KB5037771)”

The file is new, so I cant say performance was better earlier. Other files had some pauses, this particular project seems to really bring out the not responding issue. I notice the blocks really affect screen redraw. Could the modeling of these items be the issue?

I’m going to pivot to another project and report back.
thanks again,
john

Pascal,
after investigating some more (and rebuilding files), I see the model (and color maps) may be the issue.

There are clusters of objects that were originally built in v8, then imported into a v7 model. I resaved these with multiple changes:

  • Color maps in CMYK color space, I’ve changed them to RGB and cut the resolution.
  • Originally I imported 3 objects in 1 v8 file as groups. I now imported 3 different files, each as a block.

I notice a significant size decrease (from about 120mb to 10mb, not including 3 blocks at 2mb each)

I recall other programs having issues with CMYK jpegs, is Rhino not happy with them too?
thanks, John

@John_Colby I also investigated your file. Some parts are indeed quite heavy. For instance one of your bag is a polysurface of 137 surfaces, this translates into quite long processing times before even data gets to the render engine.

All in all the file you shared causes around 15 000 mesh instances to be sent to the render engine. This is what takes much of the time.

I created a version of your file where I replaced all polysurfaces with their extracted render meshes, then created for each bag version a block definition and instanced that to replace all the original bags.

I did the same for the ropes - extracted render mesh, blocked it and replaced the originals with it. Copying and mirroring the one rope section already does wonders.

This all brings the mesh instance count down to around 200. This processes much, much faster and gets to the rendering stage quickly.

The file itself also loads much faster than your original file.

@pascal can share the file with you if you’re interested in seeing how I did things.

Oh, and based on your previous message I also downsized all images in my test. I don’t think those are the biggest problem, but if you, like you do, have only 8GB of memory on your GPU then making textures at smaller pixel resolutions is a good idea. Your data will fit better on the GPU if you are rendering with the GPU.

1 Like

thanks for the analysis and guidance @nathanletwory!
I agree I’m not super optimized and hadn’t used the technique if extracting render meshes, definitely something I’ll be doing in the future. I attribute less efficient modeling to the “fog of war”, I’m usually building 2-3 concepts a day so I’ve been less focused on efficient modeling (to my detriment) and more on getting images out…

yes, @pascal please send your rework, I would love to learn.

thanks again for the help.
-john