Rhino 6 Shadows

I’m having trouble getting a certain shadow effect in shaded mode. I would like a clean shadow edge (if possible) similar to something Sketchup might produce. At the moment my shadow edges are very jagged. Is there a setting that I should be using to achieve the anti-aliasing that I’m after?

(These objects are large and the template is set to “large objects feet.” I have tested near the origin and away with the same results.)

Hello - that may be about it… but try setting a camera based clipping bubble and see how that looks.

-Pascal

Hi Pascal,
Thank you for the reply. I’m wondering what the thought behind this might be. Is it that crisp shadows would be achieved by a render as opposed to a screen capture?

It may be a minor complaint but getting real-time shadow response with clean edges is important for how I currently use this software (architectural design applications). As I model it would be nice to see clean shadows and during real-time client presentations this would be exceptionally helpful.

I’m not sure if you are saying that you tried Pascal’s suggestion and it is not working for you.

The suggestion didn’t achieve a result that was any better than my previous attempts. I should have mentioned that. The quality isn’t horrible but it still leaves room for someone to comment on the quality of the image on the screen (especially if they have been taken through a model in something like Sketchup).

I wanted to know a little about the reasoning behind shadow creation (perhaps it has be addressed in another thread). I appreciate that there are customization options but I feel like there isn’t really any “out of the box and it just works” functionality – I have to tailor the shadows the the geometry and view which has been hit-and-miss for me.

Viewport shadows in Rhino are made using “Shadow Map” technique, so the bigger the scene is, the less quality of a shadow you get when you zoom in. The bubble helps to mitigate it, but only for still images, it will not work that well if you move around. I believe this was done to support more lightsources and special shadow effects, but unfortunately may not be as crisp as vector shadows that are used by SketchUp or Revit.

One thing you may try is sometimes some objects (like the ground/site etc.) could be set to Receive shadows only, and not cast. Therefore the map size can be decreased. Not perfect but may improve the quality a bit.
This is set via Object Properties Panel.

For architecture use and crisp shadows Rhino implementation is not perfect, sorry.

–jarek

Thank you, Jarek. I appreciate the insight.

I believe Rhino to be the best modeler for my needs (and far superior to Sketchup) but I’m constantly being asked to justify its utility when it comes to front-end presentation purposes (I can always make the argument due to all of Rhino’s other functionality/plug-ins but there is a visual expectation that the viewer now has due to other software that has become very important).

Are there future plans to address this concern for architecture users?

2 Likes

I am not aware of any plans, as much as I also would welcome precise shadows that are model-size independent. Maybe @jeff can chime in at some point to let us know what the future may hold for Rhino display.

Are there any updates on this?

It´d be very helpful to have sharp shadows with disregard of the model size, mostly to calculate overshadowing on large urban spaces.

1 Like

I agree with @rafael that sharp shadows are critical for Urban Planning.
I have similar difficulties rendering large sites and am developing work-around strategies using duplicate display modes (1st to model with, 2nd using cycles to render accurate shadows for image production). Having a shadow line drawn on vectors could be a very powerful tool for 2D and Make2D drawings as well.

1 Like