Rhino 6 Projection/Intersection Bug

There seems to be a bug with Rhino 6 when projecting or intersecting curves (or their extrusions) with a surface or a polysurface.

This first occurred during projecting the curves in Grasshopper.

Just copying and pasting the same geometry in Rhino 5 , then projecting or extruding then intersecting, works as it is supposed to.

Fixes tested, but did not work:

  • Rebuild the surface.
  • Rebuild the curves.
  • Project from top view.
  • Use the curves for trimming in top view.

The only thing that is working is Rhino 5, but that’s obviously not a solution!

Attached is a sample

Bug_Projection.3dm (176.9 KB)

Hello - I see that, thanks for the report - you can make it work by replacing the surface with a PlanarSrf - DupBorder, delete the surface and use PlanarSrf on the curves. My guess of the moment is that modeling at .1 units tolerance may have contributed to the problem - I’m not sure, but I would model at .01 at the largest - Rhino is generally happiest between .01 and .000001.



Actually, the original file where the geometry was copied from was 0.001.

And another instance where this was happening, was when the curves are projected onto a brep that is made of joined trimmed first degree and third degree surfaces. The gaps in the projected curves would occur at the seams between the surfaces with different degrees.

@SherifTarabishy - thanks for this report - it turns out this revealed a serious bug that has now been fixed.


@pascal - Thank you for following up on this, this is still bugging me as it is causing lots of problems in a project I am working on.

Not sure if this is solved with the fix or not, but it seems this is always happening when using Breps generated from Rhino.Geometry.Brep.CreateOffsetBrep() as shown in the attached GH file.

Hope the fix solves this.

Projection_bug.gh (27.7 KB)

RH-47970 is fixed in the latest Service Release

Still having a similar issue, on 6.24.
Using a line to trim polysrf in vertically in topview, doesnt work unless you have ExtendCuttingLines=No
Which makes it so you can’t trim polysrf’s with an extended cutting line in the Cplane of use, typically TopView for me, during modelling.
You have to draw a line the full length past the object to trim the object, or keep changin command modifier during use.

Hi Todd - I am not finding that to be true here in our latest; can you post an example?


I seem to have some weird inconsistencies.
The back too (longer to polysrf’s) are extrusions, the shorter too are closed polysrfs,

Object Details.


ID: 04191fdc-409d-44c2-9c2b-db90d074016e (39010)
Object name: (not named)
Layer name: Default
Render Material:
source = from layer
index = -1

Valid polysurface.
closed solid polysurface with 12 surfaces.
Edge Tally:
30 manifold edges
Edge Tolerances: all 0
Vertex Tolerances: all 0
Render mesh: 12 fast meshes 126 vertices 77 polygons
Analysis mesh: none present


ID: 135cf57d-169b-45f3-b4c4-55ce12749ae4 (40433)
Object name: (not named)
Layer name: Default
Render Material:
source = from layer
index = -1

Valid extrusion.
Extrusion Surface
“U”: Closed (-787.188 <= U <= -0)
“V”: (0 <= V <= 1725.77)
Path: (34123.8,-862.883,-176.085) to (34123.8,862.883,-176.085)
End caps: start and end capped
End miters: square start and end
Profile curve:
NURBS circle
center = (-2.84217e-14,125.285,0)
radius = 125.285
start = (0,0,0)
end = (0,0,0)
degree = 2
control points: rational, count=9
knots: non-uniform, domain = -787.188 to -0
clamped at start and end

Trim Test.3dm (400.5 KB)


Hi Todd - your initial comment said Top view - that is where I tested - can you do all the trimming in Top and see if that does what you expect?


Hey @pascal,

Thanks for taking the time.
Video below. Same issue.
But i did reopen the file I exported yesterday, and everything works as expected there.

Yesterdays exported file, tried again this morning
Everything working perfectly. Still not sure why my other file isn’t working.
I checked a few other files, and they seem to be working fine.
Something strange with

Hi Todd - can you send us the file that does not work? (tech@mcneel.com, to my attention, please include a link back here in your comments.)

@todd.o.brien - thanks for the file - I’ve added a bug track item here:
RH-57981 Trim fails according to object visibility
@todd.o.brien - I got your notes with the extra details on tech@mcneel.com., thanks for that. Something is amiss on that system and I could not reply but I did get them and I’ve passed the information on to the developer.