Rhino 6 - Problems with Outlines not showing up in viewports


(Johne) #1

I just installed Rhino 6 and see that outlines do not show up in the viewports. When I draw a curve or create a solid object (e.g. cube), the outline shows up when creating the object, but when I’m done, the outlines all disappear. This occurs in Wireframe mode and a few others. I can select the object and transform it with the gumball manipulator handles, but there is still no outline when selected. No outlines show up on any objects no matter what.

Is this a known bug, or is my version of Rhino in some sort of weird state?


(Miled Rizk) #2

Hi,

Is Surface Edges checked in the Display Panel?


(Johne) #3

Sorry for the delay. Yes, I have all of those display options set to ON. I compared Rhino installed on two separate machines, and the settings are identical, yet on machine has the missing wireframe outlines. I even tried uninstalling and reinstalling. Same problem persists.


(Nathan 'jesterKing' Letwory) #4

Can you post the result of the Help > System Information menu for the machine this fails for?


(Johne) #5

Yes. Will have to do it later tonight when I get back home. :wink:


(Nathan 'jesterKing' Letwory) #6

Sure, whenever you manage is fine (:


(Johne) #7

Rhino_6_System_Info.txt (1.6 KB)


(Nathan 'jesterKing' Letwory) #8

You could try disabling GPU tessellation under Tools > View > OpenGL if that makes any difference.

You may want to at least update your GPU driver. This is the latest available: http://www.nvidia.co.uk/download/driverResults.aspx/132000/en-uk . After updating you may want to ensure GPU tessellation is turned on again.


(Johne) #9

Thanks Nathan! Disabling the GPU Tessellation did the trick. Now Surface Edges and Curves show up in Wireframe and other diplay modes. :slight_smile:


(Wim Dekeyser) #10

Yes, but know that this causes all curve-drawing work to be sent to the CPU instead of the GPU and that this comes with a performance hit. Really, the best would be to update your GPU drivers.


(Johne) #11

Yeah, I’ll definitely give that a shot as well. In the past, I’ve had some
problems with the newer drivers failing, so that’s why I’m using an older one.


#12

Hello,
same probleme here:
grafik

rhino_6_system_info.txt (1.6 KB)

Does anybody know how to solve it?


(Julianiklasson91) #13

Same problem, system information:

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Evaluation, build 2018-11-07
License details: Stand-Alone
Expires on: 2019-03-05

Windows 7 SP1 (Physical RAM: 12Gb)
Machine name: STATION-11

GeForce GT 630/PCIe/SSE2 (OpenGL ver:4.4.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: 3-4-2014
Driver Version: 9.18.13.3523
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Pascal Golay) #14

Hi Julian - I’d look first at getting a newer driver from the NVidia website - that may sort things out.

-Pascal