Rhino 6 potential bug

there appears to be a bug in Rhino 6 that will prevent a curve (object) from being properly displayed once a section cut ( mirrored clipping planes) are turned on for a model. The cplane is set to a surface and there is sufficient space on either side of the surface. The object is drawn with project on so it will only draw on the cplane. Once drawn the item is not visible but is selectable and dashed when selected. Once the clipping planes are turned off, the object is clearly shown again on the cplane.


Hello - I see two other clipping planes at right angles - what happens of those are disabled? Or are they?
I think the dashes are the control polygon being drawn as the points come on with selection.


the other 2 clipping planes are similar clipping plane pairs but are currently disabled. When the clipping plane in question is turned off and the curve is selected the display is different, it displays with the points and no “control polygon” as you described.

Yeah, the curve is not drawing, is my guess, only the points and control poly. Does it make any difference if you

  1. Hide all the other objects apart from the line you’re drawing
    (if it is the same, please export to a new file and post it/send it to me)
  2. Turn off auto-points-on in Options > Mouse

And, can you please run SystemInfo in Rhino and post the results?

Setting up two clipping planes here, and making a line, works - can you also try different display modes including some default ones and see if the same problem occurs?


sysinfo.txt (2.0 KB)

Hello - a shot in the dark, but try changing the setting in Options > View > OpenGL for ‘GPU Tessellation’
Does that make any difference?

You could also update your driver - open the Notifications panel, double click on the message about the video drivers and follow along and update… if that turns out to help, please run SystemInfo again and post the new one. Thanks.


Hey, that worked. Thank you.

Hm - interesting, I wonder why it was off - default is on. I’d still get new drivers…


I am having display lag issues, and was testing out how to get my video card to use the allocated system memory on top of the 2GB dedicated on the video card. I turned it off to check performance and must have forgotten to turn it back on. What i comes down to is that i need a stronger video card with at least 6GB on board.