Delay and lag with simple commands

Hi. I have just installed Rhino 6 on my Dell XPS 9560 with Windows 10 64-bit, but the performance is very bad.
For example when i drag or copy simple elements/curves the objects will not follow my cursor , but they are a few seconds behind every move.
I have talked with Dell and they are saying that it has something to do with the program.

Does anyone know how to fix this problem?

Thank you!

I have Inter® HD Graphics 630, and NVIDIA GeForce GTX 1050, both up to date.

My systeminfo from Rhino 6 :

" Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Educational Lab License, build 2018-11-07
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: ARMAN

GeForce GTX 1050/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 416.81)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-2-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement” "

1 Like

Does the delay still exist after you load-protect the V-Ray plug-in?

Tools > Options > Plug-ins, right-click on the V-Ray one and choose to load protect. Then restart Rhino.

Yes, the delay is still here. When I disabled the V-Ray plugin the delay became a little bit better (not perfect). So maybe it is the v-ray that causes the problem?

Is it better when you have only a display attached to your GTX ?

If you mean to disable the Inter® HD Graphics and only use the GTX, then no, still the same

When I do the “testmaxspeed” command I get ; “Time to regen viewport 100 times = 8.98 seconds. (11.13 FPS)”
I don’t know if this has something to do with the problem ?