Rhino 6 Osnap

The Mid and Endpoint features of the Osnap are suddenly not working. I am using the Polyline tool and I was creating a sort of tetris shape and on my third line, I was trying to draw a line that is half the length of the one that is parallel to it and it would not SmartTrack to the midpoint of that longer parallel line. (refer to image below)

I’ve looked into the other forum posts and tried adjusting things in the Modeling Aids section of Document Properties. Still no luck.

Any idea how to fix this?

Here anyway, it looks like you have to pick up the two endpoints first in order to get the midpoint smart track to kick in… I don’t know how long it’s been that way, but V5 seems to behave the same way.

Hello - just for variety, Tab direction lock plus Between and Point Osnaps will do it.


1 Like

@buzzawayy - I think the problem here is - and this might just be me making things up - is that at this point you only have a preview of the Polyline, not the actual geometry, so it can’t locate Ends and Mids on a non-existent line. The only thing that has been created at this point, are the Point locations (no pun intended!). That’s why activating “Point” Osnap as Mitch did, worked.

1 Like