Rhino 6 - Orient3pt bug

Hi all,

I’m running Windows 10 and using Rhino 6 with a model of some complexity and encountering a breaking issue with Orient3pt. It seems to be a little graphic sugar added to the command wherein after the first 3 reference points are selected, a copy of the reference object becomes glued to the cursor, then as target points are specified this floating object animates its way into position.

This seems nice enough, but with a large part and a complex model, this clone of the reference object glued to my cursor is making it impossible to select target points.

I have tried enabling and disabling the copy option in the command, I have tried different osnap combos, and toggling them on and off.

To be exact, the sticky object on the cursor obscures the entire viewport, and once I do manage to reveal a target point, I cannot select it, regardless of my settings. I can make a video next week.

Are any other users having this problem?

I can see why this feature was conceived, but there should be an option to toggle this new behaviour on or off.


Hi Natalie - can you change display modes temporarily, for now?

@natalie - for now, here is a quick and dirty Python that just lets you place the points un-encumbered.

Orient3PtEx.py (1.5 KB)

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes"